Question DH61WW Motherboard - Having RAM/BIOS issue

Jun 3, 2020
7
0
10
0
Hi all,

Hoping for a bit of help, any comments/suggestions will be very gratefully received!

I am currently running an old Intel Motherboard - DH61WW this is working fine with 2x 2GB of DDR3 1333Mhz RAM. Problem I'm having is as I'm trying to upgrade to 2x 4GB of DDR3 1333Mhz - the machine isn't recognising these, so much so that I can't even get it to boot into BIOS. The machine puts power to the board, fan spins, then it all stops. Pretty sure the RAM is fully inserted both rows are clipped into place. Did take them out and re-seat them to make sure.

If I re-install the original RAM it works straight away.

I'm aware I'm running an old version of BIOS - but since Intel pulled the update manager, I'm struggling to find the updates from a secure website - not even sure if I need to update the BIOS as the motherboard should support 16GB of RAM. The current version of my BIOS is BEH6110H.86A.0046.2012

Do I have defective RAM (I don't have another PC to try on)? Am I doing something wrong, or missing a step?

Thanks in advance.
 
Jun 3, 2020
7
0
10
0
Thank you @helpstar - I will try that later tonight. I tried inserting both modules at once rather than one at a time. But will try inserting one at a time as well.

I've only ever cleared CMOS once before - will have a look for the board manual to make sure I do it correctly!
 
Jun 3, 2020
7
0
10
0
As an update - i cleared the CMOS and was able to install one row of the 4GB, however when I swapped to install the second row it went through the same issue as before, powering on and off, tried both bays with that chip and nothing works, can only conclude that the RAM module must be faulty - it was purchased as second hand, so will try and return and get a replacement. Fingers crossed that works - thanks for your help.
 

ASK THE COMMUNITY

TRENDING THREADS