Question Directx 11 games running poorly (low GPU usage) ?

Oct 16, 2021
2
0
10
0
Hi all,

First time posting here.
Just a quick summary - had an issue with an old SSD dying on me. This forced me to reinstall windows 10 to another less dead SSD. However, after reinstalling and making sure everything was fully updated I've found that games that rely solely on Directx 11 absolutely suck for performance (previously where I was getting great results before the reinstall).

After a full day of troubleshooting and installing new and old drivers to test everything - I've found that every game that runs in DX12, Vulkan, OpenGL etc run brilliantly (especially the new Back4Blood when ran in DX12 and some more intensive games) but anything that runs in DX11 hits a major dive in performance (the Forest, Dark Alliance, Destiny 2, Back4Blood - when set to DX11 mode etc). I've also found that DX11 games use 2-12% of the GPU while the DX12 uses anywhere from 60-100% (even if they are the same game like Back4Blood)

When searching through the archives of the internet I'm not finding many answers (mostly just people who have performance drops moving from DX11 to DX12 when mine is the opposite).

Any insight you have would be greatly appreciated - I've went through and updated my system with all the latest drivers (even testing older drivers to be safe) and even did a clean installation of windows 10 twice to be safe. So if you know how to fix this I'd be eternally grateful!
My specs are:

Motherboard: Gigabyte B450M DS3H (with latest BIOS)
RAM: 16 GB (3200mhz)
CPU: AMD Ryzen 5 3600 6-Core
GPU: Radeon RX 580 Series
OS: Windows 10 Pro (64-bit)

I'm wondering whether or not my GPU is beginning to throw in the towel (It's been the daily workhorse since new and would have been replaced if the graphics market wasn't so skewed right now) but that wouldn't make sense for DX12 to still be working perfectly despite DX11 running poorly?
 
Oct 24, 2021
1
0
10
0
Hello!

This is kind of crazy, I'm having the same issue but I'm on a whole different setup than you and I noticed the exact same thing with Back 4 Blood in DX11 vs DX12. I'm currently talking with Nvidia support so I'm waiting on a response from them but here's my setup:

Gigabyte Z390 Aorus Elite
i7-9700kf
Gigabyte RTX 3070ti OC
32 GB RAM at 2400 MHZ
Two Samsung SSD 970 Evos

I also experienced the issue both in Windows 11 and Windows 10. I attempted doing the DX11 redist on both OS installs, multiple drivers on both installs, and no luck whatsoever. That's so bizarre, I don't think it's our GPU's but there's gotta be something else going on here.
 
Oct 16, 2021
2
0
10
0
Hello!

This is kind of crazy, I'm having the same issue but I'm on a whole different setup than you and I noticed the exact same thing with Back 4 Blood in DX11 vs DX12. I'm currently talking with Nvidia support so I'm waiting on a response from them but here's my setup:

Gigabyte Z390 Aorus Elite
i7-9700kf
Gigabyte RTX 3070ti OC
32 GB RAM at 2400 MHZ
Two Samsung SSD 970 Evos

I also experienced the issue both in Windows 11 and Windows 10. I attempted doing the DX11 redist on both OS installs, multiple drivers on both installs, and no luck whatsoever. That's so bizarre, I don't think it's our GPU's but there's gotta be something else going on here.
Hi there!

Good to know I wasn't alone in this issue.

I managed to fix my issue and I've tested it on both the old and the new GPU (as i ended up upgrading just in case that was the issue, turns out it wasn't but I got a 3060ti at a good price either way) and it's been working fine since. It ended up being the latest update of windows 10 that caused my problem. I read similar problems that people experienced with versions 20h2 then moving to 21h1 of windows.

My fix was formatting and installing 21h1 from May 2021 and not updating it at all! As it seemed when I opened a directx 11 game it installed direct x separately and then began working brilliantly which I don't believe occurred previously when I installed Windows and updated (to the newest) immediately before installing any games.
At the moment I have not updated my windows to the latest update and everything is running perfect for me - I will have to try updating soon (as I have paused updates for the meantime) but will do that when I have time to troubleshoot in the event it happens again.

Hope this helps you a little bit to understanding your own issue as well!
Wishing you the luck of the silicon gods!
 

ASK THE COMMUNITY