[SOLVED] Displayport "cable not connect" problem

tsunme

Honorable
Jul 21, 2013
189
0
10,690
2
So I purchased a new monitor today and set it up and it works perfectly fine, BUT, my old monitor that also ran on DP no longer is detected. I'm using the same DP cable i was using before, I've tried a different one, I've tried the "unplug it for 1 minute to reset" thing and it doesn't work. I've updated graphic drivers and restarted and still nothing. I'm at a loss and I figure it's an easy fix somehow, but I just can't seem to find it.

Monitor: Acer K272HUL
GPU: MSI GTX 980
 

SkyRock1986

Great
Feb 28, 2019
182
9
95
0
This will sound strange but do this anyways. Power off computer, hit power supply switch, take monitor turn it off and unplug it from power source, wait about 30 seconds, plug it back in and turn PC back on. Display port should work again. Its like a switch. your monitor will retain a setting and sometimes get stuck. DO in that order
 

tsunme

Honorable
Jul 21, 2013
189
0
10,690
2
I've tried that before, I just tried it again, didn't work.
Is it possible that my gpu won't allow 2 DP monitors to be going at the same time? Can only 1 run using DP?
 

SkyRock1986

Great
Feb 28, 2019
182
9
95
0
When troubleshooting problems its always best to do it in its most simplistic form. If you have two monitors currently plugged in. try to get the old monitor up and detected solely first.
 

SkyRock1986

Great
Feb 28, 2019
182
9
95
0
I didnt realize you were trying a multi monitor setup here. You need to go to Nvidia control panel and configure multiple displays or surround.
 

tsunme

Honorable
Jul 21, 2013
189
0
10,690
2
I've had a multi-monitor setup the whole time. I've just changed 1 monitor from a dvi to DP, but my ORIGINAL DP monitor won't register anymore with DP.

I've gotten it to be detected with DVI, but it still doesn't explain why it would stop.
 

SkyRock1986

Great
Feb 28, 2019
182
9
95
0
Hmm.. typically these problems with display port is just not being securely plugged in, or the power cycle usually fixes.... you aren't daisy chaining connections you are doing dp to dp on PC, and dvi also to pc. Idk man im confused lol
 

tsunme

Honorable
Jul 21, 2013
189
0
10,690
2
HDMI works. Text and stuff is clear too. Still just baffled why DP doesn't work anymore. I've tried doing the power cycle again and using a different cable and having it be the only monitor, but wouldn't come up.
 

tsunme

Honorable
Jul 21, 2013
189
0
10,690
2
So, I have found the answer to my problem, AND, like I said, it was the stupidest reason...

So I decided to look at the input on the monitor in case i did messed it up some how and in doing so...noticed another DP input...which was the correct one to use. I'm so frustrated with my ineptitude, but am very grateful for ALL the help you have provided. :)
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS