Does Win2K service packs ruin Windows NT systems?


Jul 15, 2002
I'm administering a system consisting of a Windows 2000 server and 10 workstatins. 5 of the workstations run Windows 2000 Professional while the other half runs NT 4.0 Workstation.

Everything have been running safe and sound with only small changes the last year. But then only a few days ago someone was making a upgrade on the Visma Micro 80 program. I originally installed the program on the 2000 server and made it avavible on two NT 4.0 workstations, each wired up to a separate modem.

One of the things this guy from Visma did was installing a Windows 2000 patch soon to be included in SP3(q291244). W"hat he did wrong was before he installed it on the server he tried to install this patch on the NT 4.0 workstation originally ment to operate Visma. The following day this workstation went crazy, and since it's still been so.

After restarting this machine now comes up with the following messages "services.exe - entry point not found" and "tapisrv.exe - entry point not found". Looking in the event wiewer every error seems to involde RAS. Event IDs are 7024 and 20032. I have tried to replace involved files and to reinstall SP6a with no success. I am unable to access services or to uninstall RAS in any other way.

I'm looking forward to know if this error hang together with the running of a W2K patch on a NT 4.-0 system and how I can fix this.