• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Double boot after shutdown if XMP is enabled. Also resets memory settings.

Jul 7, 2020
2
0
10
0
Hello everyone!

So I recently built my second PC and have been having some issues with enabling my RAM's XMP profile. Here are the specs before I elaborate (I will list everything in case the problem lies somewhere else):

Asrock X570 Phantom Gaming 4S
Ryzen 5 3600 (no overclock)
G.SKILL Sniper X 2x16gb 3000Mhz
MSI Mech OC RX 5700 XT
Seagate Barracuda 2TB
WD Blue SN550 500GB
Corsair CV650 80 Plus Bronze

With that out of the way, essentially what happens is that after a shutdown (without turning the PSU off) if my RAM's XMP profile is enabled the PC will double boot and reset the RAM settings. I searched around and found that this could be the PC finding the timings and frequency to be unstable so it resets them to the default values. What's strange is that after a double boot, if I jump to the bios and re-enable XMP without turning the PC off, it boots to windows perfectly, runs stably, and maintains the settings. Manually setting the frequency and timings didn't help either.

Maybe this is irrelevant, but the PSU is plugged to the master plug of one of those extensions with a master plug and slave plugs where the slaves only get current if the master is on. I know the computer doesn't start cold every time because my previous one had motherboard LEDs and they would stay on after shutdown. Nevertheless, perhaps this can be related?

Booting from the BIOS' default 2133Mhz speed and 15-15-15-35 (or 36, I can't check at the moment) eliminates the double boot issue.

Any thoughts?

Thanks in advance to anyone who replies!
 
Jul 7, 2020
2
0
10
0
UPDATE:
I solved the issue by enabling XMP and manually setting the speed to 2933Mhz instead of 3000Mhz. I read that 2933Mhz was the equivalent to 3000Mhz on an AMD chip so I thought I'd try this to see if it solved it, and sure enough, it did. Hope this helps someone out there with the same problem!
 

ASK THE COMMUNITY

TRENDING THREADS