Question DRAM led on / no Image/no keyboard / no mouse

Jul 17, 2021
2
0
10
0
Hi all, I've just recently bought a new CPU (AMD, was intel) so I had to change my motherboard and RAM .
SPEC:
Mobo: Gigabyte Aorus ELITE V2
CPU: Ryzen 5 5600x
RAM: G.Skill Trident F4-3600C18D-16GTZRX

When I Power it on, the Red DRAM led lights up, everything else looks like its working(water cooler, Ram rgb lights, Fans) except I have no Image on Monitors, Keyboard and mouse not working..
What I've tried :
  1. Disconnecting everything and put it back togheter
  2. Remove the Mobo CR2032 for 10min and put it back
  3. Hard reset the Mobo via the CLR_CMOS pins
  4. RAM Sticks both work fine in another build
  5. Tried an other PSU and the same problem persist
  6. Tried running it with everything disconnected except the CPU ,RAM, Power cables and Case Power SW, no chance
What I haven't tried is to flash the bios via a USB Key but I expect it won't work since I can't use my keyboard.. I am stuck.. if anyone has an idea please I'm willing to try anything at this point .. Thanks !
 
Jul 17, 2021
2
0
10
0
No, I didn't think that could be related to my problem ? A faulty windows wouldn't prevent me from using keyboard/mouse and access BIOS, would it ?
 
Hi all, I've just recently bought a new CPU (AMD, was intel) so I had to change my motherboard and RAM .
SPEC:
Mobo: Gigabyte Aorus ELITE V2
CPU: Ryzen 5 5600x
RAM: G.Skill Trident F4-3600C18D-16GTZRX

When I Power it on, the Red DRAM led lights up, everything else looks like its working(water cooler, Ram rgb lights, Fans) except I have no Image on Monitors, Keyboard and mouse not working..
What I've tried :
  1. Disconnecting everything and put it back togheter
  2. Remove the Mobo CR2032 for 10min and put it back
  3. Hard reset the Mobo via the CLR_CMOS pins
  4. RAM Sticks both work fine in another build
  5. Tried an other PSU and the same problem persist
  6. Tried running it with everything disconnected except the CPU ,RAM, Power cables and Case Power SW, no chance
What I haven't tried is to flash the bios via a USB Key but I expect it won't work since I can't use my keyboard.. I am stuck.. if anyone has an idea please I'm willing to try anything at this point .. Thanks !
The red Led lit is usually a troubleshooting indicator for the CPU. (normally orange/yellow for RAM) however if it's the DRAM_LED then the fault is with your RAM.
Post will not continue until the issue is fixed hence no output to monitor.

Your CPU 5 5600x is officially rated for 3200Mhz so the IMC may not be able to control the Overclock at 3600Mhz. Your RAM as listed as OC RAM so no guarantee they will work.
If you cannot access your Bios to manually enter SPD values then update your Bios or reflash if not already done so and see how you go.

Your CMOS was brought back to default and at default you should be able to access Bios. If not then Bios may be corrupted as I don't know precisely what your interaction has been in Bios.
As far as why your keyboard and Mouse are not working is another issue and again that may be a setting in Bios regarding CSM (Compatibility Support Module).
 

ASK THE COMMUNITY