Driver at fault? Better Faster Stronger build less FPS than old build

_dawn_chorus_

Prominent
Aug 30, 2017
279
0
790
4
Rather sorely disappointed that somehow my new build is getting about 5-10 FPS lower than my last. The GPU is one of the only parts I did not change, but the drivers are now much much newer.
I am seeing this across all games too. I didn't expect a massive fps boost from these upgrades but I figured I'd see like 3-5... not a loss of 5-10.. the only thing I can possibly imagine is that its the Nvidia Driver. but I was fairly certain that "nerfing" old cards with drivers was a myth. please help.

That or the Ram timings? I assumed tighter would be better after seeing this: https://www.youtube.com/watch?v=R3ou5RVAROw
at the very least in that game, but I get less than I use to in game. The only difference is his cas latency is a bit higher.

Old build:
i7-7700
Ripjaws 16gb 2133 c15
MSI Mortar B250
EVGA 1080 SC2 - Driver 391.**
970 evo 1 tb
850 evo 500gb
Corsair RM550x

New build:
i7-8700k@4.9ghz
Ripjaws 16gb 3200 c14
Gigabyte Aorus Pro Z390
EVGA 1080 SC2 - Driver 416.94
970 evo 1 Tb
850 evo 500gb
Corsair RM850x
 

_dawn_chorus_

Prominent
Aug 30, 2017
279
0
790
4


I did. Put it in with the old Win10 install on it then just installed over it with my WIn10 USB.
 

Rogue Leader

Titan
Moderator


Ok as long as you wiped the drive when doing it should be good. If you did not then that may be your problem right there.

I see you've overclocked it, have you tried at stock speeds - it should be faster then too. Have you checked temps?

What games?
 

_dawn_chorus_

Prominent
Aug 30, 2017
279
0
790
4


When I booted from the Win10 usb it gave me the option to format the drive then install windows, so thats the way I did it.

I left it at stock speeds until after I installed a couple games, then I noticed it. I tried the profiles the board offered for 8700k @ 4.8, 4.9ghz and since have lowered the voltage a tiny bit.

Vermintide 2 and Assasins Creed Origins bot have about a 10fps loss and The Witcher 3 about 3-5.
 

_dawn_chorus_

Prominent
Aug 30, 2017
279
0
790
4


When I booted from the Win10 usb it gave me the option to format the drive then install windows, so thats the way I did it. That should have done it no?
 

_dawn_chorus_

Prominent
Aug 30, 2017
279
0
790
4



and yes I have awesome temps. Had the chip Dellided and a Dark Rock Pro4 on it. stress test at 4.9 1.33 volts never got above 71c.
 
make sure the mb has the newest bios on it. make sure you installed the newest intel chipset drivers. one issue that pop up over the past few weeks is the nvidia drivers and the 1x gpu some people we getting slower fps with newer drivers. try using ddu in safe mode and try the older 39x drivers.
 

_dawn_chorus_

Prominent
Aug 30, 2017
279
0
790
4


Sorry not familiar with these abbreviations. What is "ddu" and what is the difference between 1x and 39x?
 

Rogue Leader

Titan
Moderator


Hes saying to download this

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

To fully remove and delete your Nvidia drivers, and try the older drivers versions that begin with 39x.x

Some people have been reporting low fps issues with the newest drivers.

And yes the Windows install was done properly.
 

ASK THE COMMUNITY