dual channel memory issue

I am having a problem with dual channel memory mode.

Here's my setup:

Motherboard: Gigabyte S Series MA790X-DS4
CPU: AMD Athlon X2 dual-core 5600+ (Brisbane)
OS: MS Windows XP Pro, Service Pack 3
Memory: I have tried two matching 1GB sticks of Corsair XMS2, OCZ Platinum Rev 2, and Crucial Ballistix. All three sets were DDR2, PC6400, 800 Mhz of dual channel memory. For each one the BIOS configuration was set to 4-4-4-12, 2T, and 2.1 volts per specifications.

I started with just one memory stick in DIMM slot #1. The pc booted without any problems. I inserted a second memory stick in DIMM slot #2 for dual channel mode per instructions in the manufacturer's manual. The pc would not boot. I tried the usual CMOS reset, battery out, etc. etc. The pc would not boot. Thinking I might have a bad memory stick, I tried the memory in a friend's pc. They memory worked in dual channel mode. I also borrowed other matched pairs from friends. They would not work in dual channel mode in my pc. Next, I tried one stick in Dimm slot #1 and a second stick in DIMM slot #3. The pc booted without any problems but the memory was operating in single channel mode. The BIOS, CPU-Z, and other diagnotic utilities all indicate the memory is in single channel mode.

What do I need to do for the memory to operate in dual channel mode? Am I missing something?


Mar 11, 2008
First thing to check is your BIOS version if its F2 or better there is no need to flash your BIOS, F2 is the only one that addresses memory issues. Later then F2 only corrects or adds support for Phenom cpu's.

Second thing to check is if one stick of memory will work in slot #2 or slot #4, that will show if you have a dead memory channel in your system.

When you installed that second stick of memory you may have damaged the board with a static discharge if you didn't take proper care. Unfortunatly with the AMD processor the memory controller is on the cpu. This could mean if your board won't recognize a single stick of memory in either slots #2 or #4 you may have damaged your cpu. If memory doesn't work in slot #2 but does in slot #4 then you damaged the motherboad.

If memory works in slot #4 the try both in the orange slots and see if they work in dual channel.

I agree there's no need to update the BIOS. The motherboard came with Award BIOS Version F3. Version F2 was the previous version that addressed cpu and memory compatability.

Inserting just one memory stick in either DIMM Socket #1 or DIMM Socket #3 and the pc boots okay.

Inserting just one memory stick in either DIMM Socket #2 or DIMM Socket #4 and the pc will not boot.

Inserting two memory sticks in DIMM Sockets #3 and #4 and the pc will not boot.
I checked manufacturer's web sites, FAQ's, and forums. It appears as if motherboards and CPU's are not always compatible despite manufacturer's claims. The problem seems to be the memory controllers in certain CPU's.

I discovered an AMD Athlon X2 dual-core 5000+ or 5200+ Brisbane should be compatible with dual channel memory and my motherboard. I went to my local electronics store to purchase a new CPU. They still had the 5200+ in stock.

I pulled the 5400+ and installed the 5200+. Just for the heck of it I installed four 1GB Corsair XMS2 memory modules. The pc booted right away and the BIOS recognised all 4GB. No problem. I checked the memory settings, enabled EPP, and set the memory voltage to 2.1 volts. All is well.

CPU-Z reports 4GB's operating in dual channel mode. On the other hand Windows XP Pro with SP3 is displaying less memory but that issue is fairly well documented.


Similar threads