[SOLVED] EFI partition gone on SSD, failing to file OS loader

Vicaris

Distinguished
Feb 1, 2013
69
0
18,630
0
So overnight my SSD stopped being recognized as a boot device. Windows startup repair doesn't work and in general windows can't seem to repair itself on this one. I get error 0x57 and 0x2 logged on SrtTrail.

It might be hardware damage, it might be a software issue, I'm guessing a known firmware issue on my SSD (Kingston A400 240gb).

I've tried chkdsk /f /r /x on the drive but couldn't get things to work. It did find errors but fixing them wasn't enough.

Using scannow I found a corrupt file that couldn't be fixed. Here's the CBS log with details which I don't know if are useful or not:
https://file.io/Qe0LbFah3346

The log is massive and the problem happened on January 13th, that's also the last date in the log.

Here's hoping it's a sortable issue that can be done with just a few cmd lines.

If, however, it is indeed a hardware issue, how successful is a formatting? I can access the files in the drive just fine, read and write.

Thanks in advance.
 

ASK THE COMMUNITY