Question External Hard disks make my Desktop slower

Sep 6, 2019
4
0
10
0
I have a i7 last generation intel cpu, brand new.
I used three external hard disks 4TB each with USB 3 connected to my previous desktop. It was a i5 3rd generation and it was very slow, so i decided to purchase a new desktop with last generation processor i7. The desktop costed about $1500, so it's a fairly good machine.
Unfortunately i verify that the computer is somewhat slow sometimes.
When i acess any of the external hard disks for the first time i can hear the noise of the disk starting and it takes about 4 seconds just to open a folder or file, after this then it's fast. But again if i don't access that disk for some time it's going to do the same again.
Even when i acess any internal hard disk, even the ssd sometimes for the first time is slow, i think it's because somehow it's going through some of the external drives.

Is there any solution?
If for instance i have a one 10TB external disk is it going to be faster than using these 3 4TB external disks?
If i defragment the disks will they run smoother?

I highly appreciate any help please, as i spent a good money and still the desktop it's not as fast as it coiuld be just because of the external disks.

Note:
I cleaned the old desktop, installed the OS, gave it to my son, nothing outside connected to it, except for the monitor and mouse and keyboard, and it's working fast now, real smooth.
So my conclusion is really that with the very heavy external drives even a modern desktop becomes somewhat sluggish.
 
Edit your Power Plan. You can get to it through Control Panel > Power Plan > [your current power plan] > Change advanced power settings or type "edit your power plan" in the start menu. Don't user Power & Sleep Settings in the Settings app.

Expand Hard Disk > Turn off hard disk after
Set to 0
Click OK
Click Save Changes
Close the Power Options window

By setting it to 0 your hard disks will should never go to sleep while your computer is on. They'll still sleep when your computer sleeps. This prevents the delay of waiting for them to spin up when Windows wants to access them.

If you aren't using Windows. You'll need to find the procedure for your OS.

Note than some enclosures automatically put inactive drives to sleep. Sometimes there is a toggle switch for this. You may have to look for software from the external's manufacturer to change this. It may be unavoidable and you'll have to buy a new enclosure.
 
Sep 6, 2019
4
0
10
0
So here's what i've done do far:
In power plan i set turn off screen never; pc in hibernation never
Then as you said i selected Turn off hard disk after and chose 0 minutes.
Didn't work.

So i further tried:
USb definitions - suspend selective usb chose deactivated
unchecked all usb controler device settings:
PC management - Device engagement - Universal serial bus - and unchecked the allow pc to turn off this device

Nothing worked all external disks still go to sleep mode, i have two Intenso and one Toshiba. I'll check now the manual of both to see if they talk about power saving.
 
Sep 6, 2019
4
0
10
0
I checked the manual of the disks and they don't mention anything about it. Tried to contact the manufacturers with no answers.
I also discovered some programs that every minute or so write a file to the disks to keep them awake, but I don't know how my windows disables this program.

So all in all I have to stay with these damn drives sleeping all the time.

Thank you anyway.
 

ASK THE COMMUNITY

TRENDING THREADS