• Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Question External SSD drive Code 10

May 20, 2019
3
0
10
0
Hello, I just bought a Samsung portable SSD T5 drive. When I plug it in Windows gives me the triangle with the ! sign under Devices and "Code 10" under Properties. Samsung's software tells me there is no external SSD drive and won't do anything.

A couple of years ago when I upgraded to Windows 10 my then external hard drive stopped working and not finding any help online, I took out the hard drive and made it an internal one. So this is a longstanding problem and I believe it's Windows 10's, not a driver issue.

Device Manager tells me the USB and chipset drivers are up to date.

I have a gaming keyboard, gaming mouse, and a (brand new) headset plugged in to USB ports and they all work.

Please help, I don't want to have to return the T5 and I really need an external drive.

Things I have tried:

- Trying every USB port
- USB Troubleshooter ("can't fix the problem")
- Samsung tech support ("exchange it")
- Gigabyte tech support (five to seven days for a reply)
- Gigabyte tech support for drivers from Tom's Hardware link (realtek audio only)
- Driver Tonic and Driver Easy for drivers (NOPE! but I tried anyway; whatever they install, drivers aren't it)
- Microsoft tech support but I ended up like this guy https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/missing-usb-in-the-editor-registry/c84b9203-7638-4733-992f-08186af1b782 (looking in registry there is no 'USB' only key to edit, which led me to...)
- unchecked 'fast startup' in the power options per one of the responses
- there was more but my head is spinning and can't remember

Nothing has worked.

System specs:

Gigabyte mobo GA-P55M-UD2
Intel Core i5 CPU 750 @ 2.67GHz 2.79 GHz
Windows 10 64 bit
EVGA GeForce GTX 1050 ti
Ballistix DDR3 ram, 12 gb
 

Lutfij

Titan
Moderator
I wouldn't use third party app's to tell you if your system needs drivers or has anything pending. It often leads to more hair pulling. Are you on the latest BIOS update for your motherboard? Which version of Windows 10 are you on? Where did you source the installer from? You also forgot to mention the make and model of your PSU as well as it's age.
 
May 20, 2019
3
0
10
0
@electr0_90, I forgot to mention I am able to charge my android phone via USB also. But I tried the MTP thing anyway and it didn't work. Thanks for the suggestion.
 
May 20, 2019
3
0
10
0
@Lutfij , There are two versions of my motherboard and I can't tell which one I have to update my bios.

GA-P55M-UD2 (1.0) or GA-P55M-UD2 (1.1) How can I tell this? The 1.0 or 1.1 is not there.

my PSU is old, 8 or 10 years old. I just had one crap out on me so this was my backup stored in a closet somewhere. It is 480 w total output which is fine according to the internet. I'll get back to you on make and model.

I sourced the T5 Samsung software from the Samsung website if that's what you're asking.

Windows 10 version 1803, build 10.0.17134

Hope this is what you are looking for and that it helps you help me, heh.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts