Failure to boot after failed update (Virgin braodband was down)

Nov 16, 2018
2
0
10
0
I'm a bit desperate as all my work is on this desktop, and you guys are my only help. Professional help, I mean. The Microsft support was asking me to do restarts and the guy was reciting from the help docs.
First I need to describe initial conditions:
HARDWARE:
Mainboard ECS H61H2-M2
CPU: Intel Core i3 2120
RAM: 16GB DDR3 PC3-10700 (667MHz)
HDD: WDC WD30EZRX 3TB

Now, I did not have Windows 10 installed in the first place, I was doing the free upgrade at the time from Windows 7.
Structure of my partitions are as follows:
100 MB - System Reserved
500GB - Windows Drive
300 GB - Data Drive
1.3 TB - Storage

My disk was never converted to GPT, as when I bought it I just clone the old one (of 1TB) to the new one. So disk is still MBR.

Now, what happened 2 nights ago, was probably a failed update (Virgin broadband was down, so I'm thinking a failure in getting files is the cause).

CURRENT ISSUE:
Windows starts, attempts repairs, fails. Checked the log file, it says bootres.dll is missing.
Tried the bootrec /fixmbr (completed), tried bootrec /fixboot, I get an access denied message.
Tried to use chkdsk to the windows drive, tooks 4.5 hrs, no problems.
Tried to rebuild boot with bcdboot command, on both partitions, the system reserved one and the windows partition. it only created the files for firmware type UEFI, if I try mine (MBR), it created no files. if I try option ALL, again, it only creates the \EFI\Microsoft\Boot and my failure message remains the same: bootres.dll is corrupt.
What solutions do I have? I don't want to reinstall, I need the apps and the apps' settings and passwords from browsers, etc.
Tried in a moment of madness to reset it, the reset procedure fails at the very start.
 

viveknayyar007

Splendid
Moderator
Apr 25, 2013
3,015
1
23,215
1,040
Hello rabogdan

To fix the Access is denied error and for other booting issues, you can refer to this tutorial.

If none of the commands in the previous solution fixes the issue, you can try the SFC /SCANNOW Command with the /OFFBOOTDIR=D:\ /OFFWINDIR=D:\WINDOWS parameters.

Also, since the update process failed, some files might keep Windows from running normally, and to address this, if possible, you can Start Windows 10 In Safe Mode, and delete all the contents from the C:\Windows\SoftwareDistribution folder.

Hope this helps.

Cheers!!
 
Nov 16, 2018
2
0
10
0
Tutorial did not fix anything. However, after searching hundreds of solutions online, I've managed to find one. Ridiculous as it seems, I had to download version 1703 to be able to fix boot. and get rid of the Access denied message. That did not solve my problem in any way, just solved the /fixboot error. Now, i've managed to disable the Automatic Startup repair using bcdedit. also, used bcdedit to make sure device and osdevice partitions have the correct letter (C:).
The message I get now is winload. exe is corrupt or missing.
Question now: which distribution this file belongs to? how do I get it? it was a simple update. what was so wrong during that update that is so impossible to fix? 1703 fixed an issues with fixboot, pretty sure my update was the October one. so what winload.exe should I try then?
 

Similar threads