• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

[SOLVED] Fast speeds whenever internet is working but cuts out a lot, how to diagnose issue

Mar 30, 2020
27
1
35
0
Hi I recently built a new pc and got everything running perfect but im running into a few issues. My first issue is that im using a wifi adapter (Netgear A6210) and have no way of connecting an ethernet. I was previously using the same wifi adapter on my old pc with no issues at all however now whenever i reconnect to the wifi whether i do it manually or its because of my internet cutting out it disconnects and reconnects at least 2 times before connecting properly.

My second issue is disconnecting completely from the wifi occasionally and getting spikes of lag and packet loss most noticeable when im playing apex legends, i at first thought my issues were on the server side being an ea game afterall but im starting to think with the wifi cutting out and my reconnecting issue that it may be my end. I do disconnect in other games too btw, what is the best way to actually diagnose where the issue lies. Thanks for any help.
 
That is one of the better USB adapters to use on a desktop. Are you using the extension cable and stand that comes with it. You might try moving it to see if something in the room is blocking it. You can also add a somewhat longer USB cable ( I think 15ft is max) to see if there is someplace else in the room that works.

It could be a defective unit but that is kinda rare.

Try using the 2.4g band if you are using 5g or the reverse. Maybe one works better than the other in your house. You could also try changing the radio channel on the router and maybe that will help. In many cases it is interference from neighbors that causes this.
 
Reactions: fishpain
Have you tried moving the PC closer to the router just to see if it's an issue with signal strength?
Also....I have had great luck with Netgear adapters...I'm using 3 now...but I might also try another adapter if moving the PC closer to the router doesn't work.

If moving the PC closer works...you can extend the dongle to a better position.

I have the dongle for my living room PC up by the ceiling and I get great connection that way.
 
Mar 30, 2020
27
1
35
0
Moving the pc isnt gonna be easy or really an option, its huge and my old pc was in the exact same spot and had no issues at all
 
That is one of the better USB adapters to use on a desktop. Are you using the extension cable and stand that comes with it. You might try moving it to see if something in the room is blocking it. You can also add a somewhat longer USB cable ( I think 15ft is max) to see if there is someplace else in the room that works.

It could be a defective unit but that is kinda rare.

Try using the 2.4g band if you are using 5g or the reverse. Maybe one works better than the other in your house. You could also try changing the radio channel on the router and maybe that will help. In many cases it is interference from neighbors that causes this.
 
Reactions: fishpain
Mar 30, 2020
27
1
35
0
im not using th extension cable and unit, ill try that out and see how it goes then try switching the band its currently on both but uses 5g if it can
 
Mar 30, 2020
27
1
35
0
Unable to find the extension however upon changing to 2.4g my wifi instantly connects instead of doing the reconnect issue leading me to believe im having issues connecting to my router maybe because the adapter is much higher up than it used to be?
 

ASK THE COMMUNITY

TRENDING THREADS