Question First time build and computer doesn't show anything, please help!

Feb 13, 2020
9
0
10
0
I finished my computer build and it shows a black screen……

All fans are working, motherboard and GPU light up.

All four motherboard status LED light up in sequence, in the order of CPU, DRAM, VGA, BOOT, then no light. When I turned it off, the CPU light quickly flashes and there's a click sound.

I don't have screen yet so I connect the HDMI to a TV. I don't know if this has to do with anything.

I'm using the following components:

PCPartPicker Part List: https://pcpartpicker.com/list/QDb3dm

CPU: AMD Ryzen 9 3950X 3.5 GHz 16-Core Processor ($737.99 @ Newegg)
CPU Cooler: Noctua NH-D15 CHROMAX.BLACK 82.52 CFM CPU Cooler
Motherboard: Gigabyte X570 AORUS PRO WIFI ATX AM4 Motherboard ($259.00 @ B&H)
Memory: Corsair Vengeance LPX 32 GB (2 x 16 GB) DDR4-3200 Memory ($147.99 @ Newegg)
Storage: ADATA XPG SX8200 Pro 512 GB M.2-2280 NVME Solid State Drive
Storage: Seagate Barracuda Compute 2 TB 3.5" 7200RPM Internal Hard Drive ($54.98 @ Newegg)
Video Card: Gigabyte GeForce RTX 2070 SUPER 8 GB GAMING OC 3X Video Card ($524.99 @ Newegg)
Case: Corsair Carbide Series 275R ATX Mid Tower Case ($79.99 @ Best Buy)
Power Supply: Corsair RMx (2018) 750 W 80+ Gold Certified Fully Modular ATX Power Supply ($140.98 @ Newegg)
Monitor: Asus TUF Gaming VG27AQ 27.0" 2560x1440 165 Hz Monitor ($429.00 @ B&H)
Total: $2374.92
Prices include shipping, taxes, and discounts when available
Generated by PCPartPicker 2020-04-05 16:33 EDT-0400

Help please!
 
Feb 13, 2020
9
0
10
0
test with just 1 t ram stick? and just 1 ssd
monitor connect to the gpu?
I only have one m.2 ssd and 1 hdd. There's no monitor. I tried to connect my TV to the GPU and it's the same result.

Can you confirm if there's anything wrong? The status led doesn't keep light up, but only light up for a small amount of time.
 

ASK THE COMMUNITY

TRENDING THREADS