Question Flickering on foliage when G-sync is on

In multiple games, noteably, minecraft and far cry 6 (2 very different games), I find that turning on G-sync makes the entire screen, but most noticeably, foliage (trees, grass, bushes, ect.).

Turning G-sync off fixes this problem, but I would like to have the effect of G-sync still, I have tried looking in the monitor settings, and the only option I found that seems relevant is called adaptive sync.
No settings inside the game seem to matter.

Far cry settings: all medium, HDR10+ on.
Monitor: Samsung Odyssey G7
i7 8700k @5ghz, GTX 1080, 16gb 2400mhz ram.