Force 16 bit Z-buffer

john

Splendid
Aug 25, 2003
3,819
0
22,780
Archived from groups: alt.comp.periphs.videocards.nvidia (More info?)

I'm running Quake3 (Arena Demo) on a nVidia Geforce FX 5950 Ultra and
I want to use a 16 bit Z-buffer, but I can't get it work work. I have
added the line
seta r_depthbits "16"
to both q3config.cfg and autoexec.cfg, but it still runs with a 24 bit
Z-buffer:

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
MODE: 9, 1600 x 1200 fullscreen hz:60

How can I change this? (I'm using Windows XP).
 
G

Guest

Guest
Archived from groups: alt.comp.periphs.videocards.nvidia (More info?)

On 28 May 2004 10:52:16 -0700, compie@bigfoot.com (John) wrote:

>I'm running Quake3 (Arena Demo) on a nVidia Geforce FX 5950 Ultra and
>I want to use a 16 bit Z-buffer, but I can't get it work work. I have
>added the line
>seta r_depthbits "16"
>to both q3config.cfg and autoexec.cfg, but it still runs with a 24 bit
>Z-buffer:
>
>PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
>MODE: 9, 1600 x 1200 fullscreen hz:60
>
>How can I change this? (I'm using Windows XP).


and i would love to know how to use the 32 bit in the z-buffer.

because i've read that the bityou use the more it will render the 3d
image. ie: not rendering the pixel beind a object....

i geuss that would help any video card to be set at 32bits not 16 or
lower...?????
 

john

Splendid
Aug 25, 2003
3,819
0
22,780
Archived from groups: alt.comp.periphs.videocards.nvidia (More info?)

compie@bigfoot.com (John) wrote in message news:<f3e150ac.0405280952.6ac3c42a@posting.google.com>...
> I'm running Quake3 (Arena Demo) on a nVidia Geforce FX 5950 Ultra and
> I want to use a 16 bit Z-buffer, but I can't get it work work. I have
> added the line
> seta r_depthbits "16"
> to both q3config.cfg and autoexec.cfg, but it still runs with a 24 bit
> Z-buffer:
>
> PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
> MODE: 9, 1600 x 1200 fullscreen hz:60
>
> How can I change this? (I'm using Windows XP).

Somebody told me there should be an option in the nVidia drivers to
force the use of a 16 bit Z-buffer, but I can't find it. Can somebody
verify if such an option exists?
 
G

Guest

Guest
Archived from groups: alt.comp.periphs.videocards.nvidia (More info?)

"John" <compie@bigfoot.com> wrote in message
news:f3e150ac.0405310737.5889f409@posting.google.com...
> compie@bigfoot.com (John) wrote in message
news:<f3e150ac.0405280952.6ac3c42a@posting.google.com>...
> > I'm running Quake3 (Arena Demo) on a nVidia Geforce FX 5950 Ultra and
> > I want to use a 16 bit Z-buffer, but I can't get it work work. I have
> > added the line
> > seta r_depthbits "16"
> > to both q3config.cfg and autoexec.cfg, but it still runs with a 24 bit
> > Z-buffer:
> >
> > PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
> > MODE: 9, 1600 x 1200 fullscreen hz:60
> >
> > How can I change this? (I'm using Windows XP).
>
> Somebody told me there should be an option in the nVidia drivers to
> force the use of a 16 bit Z-buffer, but I can't find it. Can somebody
> verify if such an option exists?
>
Do a Google search for "Rivatuner". It's a great app for overclocking and
changing different aspects of your gfx card. It will allow you to turn off
the 24 bit z-buffer which will force your card to use 16 bit instead.
 
G

Guest

Guest
Archived from groups: alt.comp.periphs.videocards.nvidia (More info?)

Rivatuner has this option. However, according to the Rivatuner help file,
the option only works on GF2 MX and GF3 cards using pre-45.xx drivers, and
it increases CPU workload (don't ask me why).

16-bit Z-buffer results in noticeable clipping in Q3DM9 (two opposing jump
pads over a lava pit). Besides, on a 5950U, you will most likely be
CPU-limited in Quake III, so your framerates may actually *drop* with 16-bit
Z-buffer forced-on.

--
"War is the continuation of politics by other means.
It can therefore be said that politics is war without
bloodshed while war is politics with bloodshed."



"John" <compie@bigfoot.com> wrote in message
news:f3e150ac.0405310737.5889f409@posting.google.com...
> compie@bigfoot.com (John) wrote in message
news:<f3e150ac.0405280952.6ac3c42a@posting.google.com>...
> > I'm running Quake3 (Arena Demo) on a nVidia Geforce FX 5950 Ultra and
> > I want to use a 16 bit Z-buffer, but I can't get it work work. I have
> > added the line
> > seta r_depthbits "16"
> > to both q3config.cfg and autoexec.cfg, but it still runs with a 24 bit
> > Z-buffer:
> >
> > PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
> > MODE: 9, 1600 x 1200 fullscreen hz:60
> >
> > How can I change this? (I'm using Windows XP).
>
> Somebody told me there should be an option in the nVidia drivers to
> force the use of a 16 bit Z-buffer, but I can't find it. Can somebody
> verify if such an option exists?