Question FPS drops, high frametime spikes, normal temps ?

Mar 25, 2022
3
0
10
0
I have been experiencing FPS drops with my computer that I can not for the life of me figure out. This happens in games that I play both online and offline. I thought originally that my stuttering issues were caused by my internet but I don't believe that to be true. I usually play games in 1080p on a 240Hz monitor since I mostly play FPS games. It doesn't appear that I have any thermal throttling. My CPU tempos do reach almost 90c while running prime 95 and I get a low of 11 FPS while running heaven benchmark as seen below. At this point I suspect that this is some sort of software issue. It should be noted that my brother is in the same house in a different room with a lower end pc and experiences no issues at all on a 144hz monitor.

Current PC Specs:
EVGA 3070 ftw3
Ryzen 7 5800x
32Gb 3600Mhz Corsair Vengance RGB PRO ( 2 different 16Gig kits, 4x8Gb)
TUF GAMING X570-PLUS (WI-FI)
iCUE H150i ELITE AIO
NZXT C750 ATX PSU
SAMSUNG 970 EVO Plus SSD 1Tb

Solutions that I have tried:
Reseting my PC back to clean windows 10 install
Removing the USB 3.0 USB Motherboard connection
DDU my current graphics driver to an older more stable version
"Optimizing" my pc via nvidia control panel and performance options.
Enabling high performance power plan
Updating BIOS to multiple different versions
Running memtest86 with no errors
Use a different monitor
Use only one monitor

user benchmark:
https://www.userbenchmark.com/UserRun/51462814
 
Last edited:

Vic 40

Titan
Ambassador
My CPU tempos do reach almost 90c while running prime 95 and I get a low of 11 FPS while running heaven benchmark as seen below.

iCUE H150i ELITE AIO


user benchmark:
https://www.userbenchmark.com/UserRun/51462814
Those temps seem high for a 360 aio cooler to me. How are the frequencies of the cpu doing, if not overclocked do they at least do max turbo?

The benchmark seems fine btw. Alot of background cpu usage, maybe a antivirus or other programs that get in the way.
 
Mar 25, 2022
3
0
10
0
Those temps seem high for a 360 aio cooler to me. How are the frequencies of the cpu doing, if not overclocked do they at least do max turbo?

The benchmark seems fine btw. Alot of background cpu usage, maybe a antivirus or other programs that get in the way.
The temps do seem a bit high, but I thought that was to be expected with Ryzen CPU's but I could be wrong. I don't have any overclocks on the cpu and the frequencies seem normal to me. Below are two different screenshots of afterburner frequencies per thread:
 
Mar 25, 2022
3
0
10
0
Having the same issue, where you ever able to resolve it?

(Have had this issue with around 4 rigs with completely separate hardware too)
I was not able to fix this issue, I've been trying many different things. But at this point I think it could just be an issue with my GPU and might try to RMA it.
 

ASK THE COMMUNITY