fps weird issue

Dec 27, 2018
8
0
10
0
I have an overclocked x3440 and an overclocked RX 580 8gb card, witcher 3 with most settings on ultra, (nvidia hairworks stuff off of course) runs at 80-100 FPS most of the time, but it randomly runs at 40-50 fps some days, why is there such a big difference, i don't know what causes the drastic change in fps on some days
 
Dec 27, 2018
8
0
10
0
I have an over clocked x3440 zeon (3.8ghz) (4 cores 8 threads)
16gb 1600mhz ddr3
Radeon RX 580 8gb OC
(Liquid cooling for CPU)
(Arctic accelero extreme IV for the Radeon RX 580)
 
Dec 27, 2018
8
0
10
0
Though other games seem to run just fine as it were suppose to, the overclock on the CPU makes a giant difference it's quite good for being older
 
probably game specific issue. maybe there are certain areas where CPU usage being choke (low CPU usage) causing the frame rate to drop. overclocking of course will lessen the issue. i used to have issues with AC4 black flag in the parts which is related to CPU usage. the game used to run fine with my older 660SLI. but when i got 970 i tried to play the game once more but this time i got stutter and frame rate drop that did not exist when i still got my 660SLI. one thing that i was aware of the low CPU usage. when they go down further the frame rate will starts dropping together with GPU usage. overclocking my 2500K to 4.5ghz from stock clock immediately solve the problem. what i'm doing is i tried to compensate the low CPU usage with much faster CPU speed.
 
Dec 27, 2018
8
0
10
0


It's just weird because it runs 80-100 fps but then, same part of the game runs at 45-55, same cities ya know? Hitting a snag somewhere I suppose
 

ASK THE COMMUNITY

TRENDING THREADS