Question Games Crash On Launch

Feb 11, 2023
Hey, I've run into quite a bad problem. I updated my GPU drivers yesterday to prepare for Hogwarts Legacy but couldn't launch it. I've also noticed that this is also the case with games such as Apex Legends and Overwatch 2. HL and OW2 won't even show more than a black screen and Apex shows me the first 2 seconds of loading. However I tried Valheim, Monster Hunter Rise and The Witcher 3, which all worked with no problem.
This is everything I did prior to finding out about my problem and what I did to try and solve it.
  • Downloaded the latest NVIDIA drivers.
  • Installed them but got an error message, still it completed the install(I'm not sure if I uninstalled the old drivers with DDU beforehand but let's say I didn't)
  • I rebooted and tried to open Hogwarts Legacy to no avail.
After I tried:
  • Uninstalling drivers with DDU, reinstalling both the new, old and even the driver that released in between those but still the same issue.
  • Disk Cleanup.
  • /scfscannow.
  • Updated Windows 11 as far as I could.
  • Uninstalled & Reinstalled HL.
  • Used Restoro to try finding a problem.
  • Used HD Sentinel but no issues were found.
  • Tried reinstalling Microsoft Visual C++.
  • Tried disabling Firewall.
  • Did a double uninstall of drivers with DDU to try and remove all residual files.
  • Tried disabling XMP.
  • Tried disabling the slight OC I have on my GPU.
  • Tried finding some config file in HL directory that people said could help if changed but couldn't find.
  • Tried going back to an old restore point but the oldest ones were made today.
Drivers I Tried: 528.49(the one that got me the issue), 528.24, 527.56(the one I started with).
Asus Rog Strix 3080TI
i7 12700k
32gb RAM
~35gb free space where the games are located(all of the above are on the same drive except Valheim and MH Rise)
1000w PSU
Motherboard: Gigabyte Z690 UD DDR4
2 monitors

Thanks for any suggestions!