Question Games keep crashing and display turning on and off.

Sep 11, 2019
5
0
10
0
First off, the graphics card I bought it recently and I'm pretty sure it isn't from it because it was bought from a well-known store in my country. I mostly use my computer for work and to read/watch Netflix and it used to all be good. My previous graphics card literally melted because I left the computer on for too long but since I was awake during it the damage was only to the graphics card. Since I've tried the new graphics card everything plays smoothly but out of nowhere, even while having the computer on ""idle work"" it glitched out and the screen goes black and it turns on again and whatever page I was on I have to refresh because the videos play the sound but don't display image.

Here's what I've tried:
Changed CMOS battery
Changed Hard DISK and reinstalled Windows
Removed the CPU to check if it was burned or if it hadn't thermal paste, it had but I still cleaned it and reapplied
Changed monitors (with a working one)
Changed PSU
Swapped out RAM
Changed all the cables connecting to the monitor

Tomorrow I'm gonna put my graphics card in my family members' computer (which is working) and swap my GPU with them to see if it's from it. Until now, I'd appreciate it if any of you had any tips or had the same issues and can provide some answers!
Thank you!
 

white.a.drew

Respectable
Oct 14, 2017
645
40
2,140
42
First off, the graphics card I bought it recently and I'm pretty sure it isn't from it because it was bought from a well-known store in my country. I mostly use my computer for work and to read/watch Netflix and it used to all be good. My previous graphics card literally melted because I left the computer on for too long but since I was awake during it the damage was only to the graphics card. Since I've tried the new graphics card everything plays smoothly but out of nowhere, even while having the computer on ""idle work"" it glitched out and the screen goes black and it turns on again and whatever page I was on I have to refresh because the videos play the sound but don't display image.

Here's what I've tried:
Changed CMOS battery
Changed Hard DISK and reinstalled Windows
Removed the CPU to check if it was burned or if it hadn't thermal paste, it had but I still cleaned it and reapplied
Changed monitors (with a working one)
Changed PSU
Swapped out RAM
Changed all the cables connecting to the monitor

Tomorrow I'm gonna put my graphics card in my family members' computer (which is working) and swap my GPU with them to see if it's from it. Until now, I'd appreciate it if any of you had any tips or had the same issues and can provide some answers!
Thank you!
did you use ddu to remove all your old gpu's drivers?
 

ASK THE COMMUNITY

TRENDING THREADS