Gigabyte Motherboard drivers

GASGambit

Honorable
Sep 12, 2013
16
0
10,510
0
just got a Gigabyte GA-Z77P-D3 motherboard and installed all fine in my first PC build. the motherboard came with a CD called 'Intel 7 Series Utility DVD' and had all (im pretty sure) the drivers for the board.

my question is will these drivers be up to date enough? i have checked the website page of my model but when i try and install the drivers the wizard notifies me it is an older driver? there are no problems with the board but i want to know all the drivers are good to ward off any problems

other specs:
Intel Core i5 3570K
Corsair Vengeance Performance 1866mhz 8gb
Corsair 500W CX Builder
Windows 7 64bit home premium
 

Y0GI

Dignified


I followed the link that you posted to the d/l page which showed the following MB chipset driver:
Intel INF installation 9.3.0.1021 1.24 MB 2012/09/20
Check your driver version and date in Windows Device Manager. Look under the "Driver" tab. If your installed driver is not as new as the one shown above, install the new driver.

I also noticed that there is a ver. 1.0 and ver. 1.1 of this board. Are you checking for the correct version?

Yogi

 

GASGambit

Honorable
Sep 12, 2013
16
0
10,510
0


oh crap i hadnt thought of that, the board is Rev 1.1, so is that page incorrect then?
 

Y0GI

Dignified


The link that you posted was to rev. 1.0.

 

GASGambit

Honorable
Sep 12, 2013
16
0
10,510
0


yep you're right i found the correct page: http://www.gigabyte.com/products/product-page.aspx?pid=4238#dl

il try that and see, thank you
 

Y0GI

Dignified


You're welcome!

Good luck!

Yogi

 

ASK THE COMMUNITY

TRENDING THREADS