Question [Glitch Display] Faulty GPU, Driver-related or something else?

Sep 25, 2018
20
0
20
2
Hello friends.
How are you?

First of all, I have the following set-up:
  • Ryzen 3 1300X
  • Gigabyte B450M Gaming (rev 1.0)
  • 1 Crucial Ballistix 16GB DDR4 2400MHz
  • 1 HyperX 8GB DDR4 2400MHz
  • XFX Radeon RX580 4GB
  • Corsair CX450
Recently, after I updated my windows to 1903, I've noted some weird video glitches. The coloured vertical stripes appear just on motherboard's logo after post. [1]

Sometimes I can use my PC normally (the glitch just disappear after win10 logon screen); sometimes I can enter wind10, but after some time it appears a weird checked glitch and then it hangs [2]; sometimes the PC just works fine since boot; and sometimes I got stuck on BSOD with "Thread stuck on device driver" [3]: when I got stuck on BSOD, I shut down the PC, remove power cord, remove the GPU, then put everything on again, and it works (I've read somewhere that this error is related to the drivers).

However, today I found no other way to use my computer than putting it in safe mode.

Here are some additional facts
  • This first happened after 1903 update. Before that I just experienced some rare game crashing during Forza Horizon 4 when I put "high graphics" settings. I solved that by applying a custom profile for GPU fans in Radeon Wattman (played months after it). I was able to use PC normally. I even ran FurMark more than once to test the GPU (at the time of FH4 crashes), and it was fine.
  • In latest errors, in Event Viewer I could see a message saying that AMDKMDAP has recovered from an error. After reboot, there were a message from Wattman saying that it "was restored due to an unexpected system failure".
  • Tried a spare PSU (500W), and the glitch happened.
  • Tried the RAM sticks alone, and the glitch happened with both of them.
  • If I remove the GPU, and power on the PC, I note that the system does not hangs. (Ryzen 3 does not have onboard GPU; I check if the system is frozen by pressing NumLock key in keyboard; I left PC running several minutes, and keyboard was still responding).
  • The PC does not hangs and/or the glitch does not appear if I select Windows 10 "Safe Mode" boot option.
Have you ever seen this before? Is there a software/driver workaround that I still could try, or I'm facing a dying GPU?

In case of software/driver-related issue: why the glitch appears even in mobo's setup?
In case of hardware related: why the glitch is not appearing in Win10 safe mode? (Today, it was the only way I could use the computer)

Could it still be something related to the BIOS (either from mobo or GPU)?

I'm really curious about it.

For now, I'll perform a clean uninstall of Radeon drivers as a desperate move.

I'm really inclined to believe that unfortunately my GPU is faulty, but I need a second (and third) opinion to be more certain about it (maybe there is even some known solution that I haven't tried/read about it).

Here are the mentioned errors (when they happen, the system hangs):
[1] View: https://i.imgur.com/BdvpDjL.jpg
.
[2] View: https://i.imgur.com/ASwNg6G.jpg

[3] View: https://i.imgur.com/X7DA20J.jpg

* EDIT *

Some new (and intriguing) informations:

I performed a clean uninstall using AMD's tool, then reinstalled the driver. Everything seems fine for now. I even ran a FurMark test without a crash (in 1080p preset)!

But, in the image below (containing, from left-to-right, wattman parameters monitoring, FurMark report and GPU-Z), I noticed a discrepancy between an information given by FurMark and GPU-Z about memory clock: FurMark says it is 1262MHz, while GPU-Z says it is 1366MHz. Could it be a clue of something odd? Could a dying gpu pass a FurMark benchmark?

View: https://imgur.com/a/ZqF4neI
 
Last edited:

Lutfij

Titan
Moderator
Is the PSU you're using the Green labelled CX or the Grey Labelled CX? YOu should be on a 550 version of the Grey labelled CX in order to operate that system with an RX580 equipped. The artifacting happening during boot cannot come about from driver issues but rather of a lack of power being fed to the GPU.
 
Sep 25, 2018
20
0
20
2
Hello!

Thank you for your help!

I'm using the grey labeled Corsair, BTW.

Do you believe that an insufficient start-up power from PSU can cause that? I was considering this option as well, but I eliminated that hypothesis when I tested the system with my spare PSU (chinese, 500W, 72%) and the glitch reproduced. Also, during FurMark, the PSU should fail if it was insufficient, right?

I'm getting intrigued because I just got another flawless pass on FurMark (preset 1080p). In the ocasion I monitored the hardware stats during the test with HWMonitor, and maximum power reached by GPU was 146W. Considering the maximum TDP of my CPU is 65W, them both - together at maximum - would reach 211W. This is less than 50% of my PSU nominal maximum power. Doesn't seems that it can be a problem to my PSU (unless it is faulty, and not providing its nominal power anymore).

So, is there a software where I can monitor the power output from PSU since boot? Perhaps there is something else draining more power than it should.
 
Aug 24, 2019
5
0
10
0
Hi,

I have been getting a similar issue with my Gigabyte RX 580 too, but it seems to be specific to DOTA 2 weirdly enough. Would be interesting to know if there are any relations.

Artifacting

Maybe yours is a combination of GPU and driver issues?
 
Aug 24, 2019
5
0
10
0
Wow! Very similar issue! :oops:
Does the system freezes when it happens?
No, just goes back to desktop with the game sounds still playing in the background. Have to close the game through task manager. Seems to be API related I suspect. The constant colourful blank screens with unresponsive system went away after:

  1. Took the RAM, GPU, PSU out of the case and cleaned the motherboard thoroughly. Connected everything back again.
  2. Reinstalled drivers after cleaning out with DDU.
  3. Tried this command prompt line out of desperation
CMD

4) Underclocked and undervolted til it was running stable in most games.

The artifacting only happens when I open certain games though. Everything else is normal. Yours seems a little scarier with that boot screen. :eek:

EDIT

I've also found this If you want to give it a try.
VRAM Voltage
 
Last edited:
Sep 25, 2018
20
0
20
2
Hi.

Thank you.

I'll put some attention into it.

Since I wrote the main post, things seem to have normalized. No glitches, freezes nor even a single FPS drop... I think my set-up is haunted. :D
 

ASK THE COMMUNITY

TRENDING THREADS