GPU 3D usage spikes to 100%, black screen and crash in games

tmmshr238

Prominent
Jan 21, 2018
3
0
510
0
To start out, I should say I'm not particularly informed regarding computer hardware or software. I understand some stuff, but it'd probably be best just to talk to me like I don't know the technical terms.

A few weeks ago my brother built a computer, which I've been using to play Total War: Warhammer and XCom 2. It was his first foray into computers, but he seems to have put it together pretty well.

OS: Windows 10 x64
Processor: AMD Ryzen-5 1600 Six-Core, 3200Mhz
GPU: Radeon RX 580
RAM: 8gb

For the first 25-30 hours or so, Warhammer specifically worked pretty well. I think there might have been a crash or two, but otherwise nada. However, maybe 3ish days after purchasing the game it began to crash often. Usually the game freezes for a second or so, the screen turns to black, but I can still see the cursor and I can still hear the game in the background. If I press escape, I can hear the sound the game makes when the menu comes up. Usually I can just control-escape and close the tab. Once in a while, the game will crash in full, and the computer will freeze totally and static will begin coming from the speakers. At this point the computer can only be turned off by holding down the power button.

I tried a clean reinstall of the Radeon drivers, and updated the rest of my drivers. I tried reinstalling Warhammer. My brother reports he gets the same issue with XCom. The GPU temperature isn't an issue, it sits around 40-60 degrees Celsius. I ran Windows Memory Diagnostic, no issue. I ran task manager and MSI Afterburner while gaming to see if I can pinpoint an issue. I noticed that CPU disk usage often spikes to 100%. In fact, it's running at 100% pretty much the entire time that Warhammer is playing, with most of that usage attributed to Warhammer, but sometimes to some AMD program or another (pointing to the GPU). I also noticed that when the game crashes, the moment of the crash the GPU 3D usage spikes to 100%. The spike lasts 2-3 seconds, and then immediately returns to where it's usually sitting, between 0-5%.

So I think we can safely assume the issue is with the GPU. I'm kind of at a loss with what it is though.
 

tmmshr238

Prominent
Jan 21, 2018
3
0
510
0
Another update, I've pinpointed the crashing to the error message "Display driver amdkmdap stopped responding and has successfully recovered" (Event ID 4101). This now happens outside of games, for example the screen blacked out for about 1 second while I was writing this post. Luckily, when it blacks out outside of a game, it usually comes back. When in game, the game never recovers. I've already clean reinstalled the display driver twice, and I am monitoring the temperature. It's normal. I have checked for dust, even though the computer was only built a month ago. Also not a problem.

Coupled with (2) Event ID 4101 warnings during the latest crash/stall/whatever, Event Manager also logged an Event 10016, something regarding DistributedCOM. I have no idea what that is, but it also shows up as a very frequent error.
 
Mar 14, 2018
1
0
10
0
I'm having the same symptoms with a GTX 760 on Windows 10 that has been working for 3.5 years, and suddenly has started doing this. Same spikes of 3D usage at the moment of the crash. I'm wondering if my power supply is dying and that's what's causing it, but I hesitate to just buy one without knowing if that's the issue.

UPDATE: Decided to try buying a new power supply, since it's way cheaper than updating my GPU .... no dice. Still get black screen and crashes trying to run/load in games.
 
Mar 20, 2018
2
0
10
0
What refresh rate are you running in Windows and in-game?
Have tried enabling/disabling Freesync if available?
In AMD Setting which Scaling Mode are you running? Can you try Full panel?
 

ASK THE COMMUNITY