Question GPU and CPU utilization not 100%

Feb 24, 2020
12
0
10
0
My newly built PC has issues with some games.
My GPU never reaches 100% and my CPU neither. I'm taking Assasin's Creed Origins as example. I sometimes (depending on the place) get only 40-50 FPS. This shouldn't be the case with my setup. The GPU is only utilized around 60% at 1080p high. The CPU is also around 50-60% utilization. Some CPU cores rarely go over 60% but not a single CPU core exceeds 80%. The weird thing is that I can set my res to 4K (3840x2160) and the frame difference is barey there. Fortnite is my seconds example. I get much better FPS with this, but my frames are dropping quite often. Most of the time I stay at 110-144 FPS but the frames sometimes drop down to 50 FPS sometimes. This is really annoying and this shouldn't be the case with my hardware, plus it's not using 100% of the GPU or CPU. No bullshit like frame caps or V-Sync. Chipset and GPU drivers are installed and up to date.
Specs:
Ryzen 5 2600X
RX 5700XT
ASRock B450M Pro4
RipJaws V 16 GB (2x 8GB) 3200 MHZ
 
Last edited:

Phaaze88

Distinguished
Ambassador
Enhanced Sync is disabled in Radeon Settings?

There's also the matter of the power supply; it may not be enough for the RX 5700XT - by 'not enough', I don't mean total wattage either.
There's more to it than that - things like voltage ripple and quality of the components inside the psu, for example.
 
Feb 24, 2020
12
0
10
0
Enhanced Sync is disabled in Radeon Settings?

There's also the matter of the power supply; it may not be enough for the RX 5700XT - by 'not enough', I don't mean total wattage either.
There's more to it than that - things like voltage ripple and quality of the components inside the psu, for example.
Well I enable it for my FreeSync monitor but disable it when playing on a TV. I just checked it and yes it is off. My PSU has no problem when my CPU and GPU reach 100% by using Prime95 and Furmark. (That's the only way how I can get "full utilization".)
 
Feb 24, 2020
12
0
10
0
But that's not at the same time, is it? I'm not suggesting you actually do that.

Post the URL to your results. Oh, and close the browser before you run it.
I tested it at the same time. The CPU is at 100% and the GPU is between 98-100%. It runs fine without instabilities or crashes. Userbenchmark: https://www.userbenchmark.com/UserRun/24955060
That's odd I already got 98% in the Benchmark. Maybe the current issue is the 4K TV I connected my PC to?
 
Feb 24, 2020
12
0
10
0
I'm not seeing anything out of the ordinary.

It may very well be that the problem lies with the TV.
Have you tested with different cables yet?
How about a different monitor/screen?
I have tested it with my 1080p 144hz FreeSync monitor at home and this TV. But I'm sure I got 98% with my monitor at some point and 97% with the TV at some point.
 
Feb 24, 2020
12
0
10
0
That's pretty much within margin of error...
A single cpu core doesn't necessarily have to be at 100% to be considered maxed out; it can happen at 92%.
I was talking about Userbenchmadk scores, not CPU utilization. A single CPU core rarely goes above 60% when gaming and never above 80%.
 
Feb 24, 2020
12
0
10
0
I meant that as an example. I guess it wasn't a good one...

Gpu usage at 99% on one run, 97% the next run, and 98% on another, is pretty moot.
Hmm so that won't explain my issue ingame. I don't get what the issue should be when I still have every resource available (CPU, GPU, RAM).
 

Phaaze88

Distinguished
Ambassador
Hmm...
-You're not running a multi-monitor setup?

-Using two separate 8 pin connectors from the psu?

-Are you able to switch to DX12?

-Try right clicking on Radeon Settings icon in taskbar -> graphics profile -> select optimise performance instead of balanced by default.

-In global wattman, set to auto overclock gpu.
 
Feb 24, 2020
12
0
10
0
Hmm...
-You're not running a multi-monitor setup?

-Using two separate 8 pin connectors from the psu?

-Are you able to switch to DX12?

-Try right clicking on Radeon Settings icon in taskbar -> graphics profile -> select optimise performance instead of balanced by default.

-In global wattman, set to auto overclock gpu.
-Single monitor

-Yes, but one connector has 2 extra loose pins.

-Not for AC Origins (the game I have the most problems with) but for Fortnite. The FPS are even worse with DX12 in Fortnite.

-The translations to german are vague, the best I was able to do was to set "video profile" to "enhanced". No improvement.

-wth is Wattman EDIT: I did it but no difference.
 

ASK THE COMMUNITY

TRENDING THREADS