Question GPU isn't being recognised by the motherboard

Oct 5, 2021
2
0
10
0
Hello!
My Sapphire Radeon R9 390 isn't being recognised by the motherboard. There's a red VGA light and the number 40 on the ASUS motherboard. It doesn't boot to BIOS, screen is just black. Otherwise everything sounds and looks fine. The fans on the GPU doesn't move though, BUT when I turn the PC off the fans on the GPU wiggle a bit, like it has power. I have checked and unplugged all the wires several times (wires are new so no damage, even tried 3 different new ones) and I've checked the motherboard and the slot for damage. I'm pretty sure I can rule out some physical damage to the GPU or the motherboard slot since I've been very careful with everything.

But wait, there's more!

I just upgraded my PSU from an old 500W to a Corsair RM850 850W (to be able to use the newer graphics card).
My new PSU works fine with my old Nvidia GeForce GTX 670! It's just the newer GPU that isn't recognised.
The newer GPU worked with the old PSU, until I ran a game that needed some more power, then it shut off the computer because the PSU was too weak...
Any ideas?

Some specs, if you need more just ask:
Intel(R) Core(TM) i7-4820K CPU @ 3.70GHz 3.70 GHz
RAM 16GB
64-bit Windows 10
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Model for your Asus motherboard? Can you mention the SKU to your Sapphire GPU? If not a link to the GPU will help two fold? The R9 390 isn't exactly new., do you mean it's brand new or that the purchase was new? Make and model of your older PSU and it's age? If you were previously on the GTX670, you're advised to remove the GPU drivers using DDU prior to removing the GTX670 to drop in the R9 390. try another slot on the motherboard lower down to rule out a glitchy PCIe slot.

On second thoughts, please parse your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS: include version(not edition)

and the parts you've used to swap between them to diagnose a faulty part.
 
Oct 5, 2021
2
0
10
0
Hello, thank you!
And thank you for taking the time to help me. I'm not very tech savvy but I'll try to answer the questions as well as I can.
I got the computer from my ex who had bought a new PC and gave his old one to me, including the GPU and everything, hence why I'm a bit clueless about the parts :)
BUT the PSU is brand new, bought it just the other day.
The GPU isn't new but it's newer than my current one, that's why I called it the "newer" one hehe... here's a link to it. I believe it's been discontinued basically everywhere:
https://www.amazon.com/Sapphire-Radeon-Version-Graphics-11244-00-20G/dp/B00ZGL8CYY
I've tried putting the GPU in the other PCIe slots but the problem persists. Cables from the GPU to the PSU are brand new.

CPU: Intel(R) Core(TM) i7-4820K CPU @ 3.70GHz 3.70 GHz
Motherboard: ASUS Rampage IV Gene Rev 1.xx
Ram: 16GB, DDR3.
SSD/HDD: 1 SSD + 1 HDD. Operating system is installed on the SSD. I'm not sure if you want serial numbers or?
GPU: Nvidia GeForce GTX 670 (current one) / Sapphire Radeon R9 390 (the one I wanna use)
PSU: Corsair RM850 850W (current) / Cooler Master Silent Pro 500W (old one)
Chassis: I'm pretty sure it's a mid-tower? Not sure how to determine this other than the size of the motherboard and my own perception of the size...
OS: Windows 10 Home, Version 21H1

It's pretty late here so if I have forgotten something, please let me know!
 

ASK THE COMMUNITY