GPU usage low while gaming.

Pdemocracy

Commendable
Jan 16, 2017
2
0
1,510
0
Hello, I have an i7 4770k and a evga 1070 sc. It runs fine in most games but some games I notice that I am not getting as many frames as I should. I use afterburner and I notice that when this happens my gpu usage is not even pushing 50% sometimes. My temps are fine and there doesn't appear to be a cpu bottleneck on any of the cores when this happens. I have already set nvidia control panel to maximum performance. I have tried every thing I can think of, I even reformatted. I give up, please help!
 

Pdemocracy

Commendable
Jan 16, 2017
2
0
1,510
0


Here is a quick run down.

GTA V (Gpu sometimes gets into the 70's% but usually never). I get from 55-85 fps. After reformatting, the gpu usage went into the 90's and I was getting over 100fps, however after a few minutes the usage and fps went down to it's previous state.

Depth. (Gpu doesn't even go above 50 most of the time). At the menu's gpu usage might go up and push 144fps but once I get in game the usage and fps go down again. I had the same luck after reformatting, but then it went back to the same problem shortly after. (This game is not demanding at all)

Rocket League. No problems here, 144 fps and high gpu usage.

Rainbow Six Siege, No problems, gpu usage is always in the high 90's and I push over 150 fps.

Doom: I get good fps, always over 100, but the gpu usage never goes above 70%, it usually hovers in the 50's. It appears that I suffer from the same problem in this game too.

For all the games I max out all of the settings, v-sync is off, and refresh rate is set to 144 or unlimited.
I understand that optimization varies from game to game, but shouldn't my gpu at least be trying like in Rainbow Six Siege?
 

Andrewthegreat

Commendable
Jan 14, 2017
99
0
1,660
7

Did you try with v-sync on?
Did you also try using the recommend game settings in GeForce experience and getting driver updates for your gpu
 

ASK THE COMMUNITY