Question GPU-Z displaying my GPU at x1 3.0 instead of x16 3.0 - Terrible performance in some games

Aug 11, 2021
3
0
10
0
Hello, I was having massive fps drops / stuttering with the game Prey and started to investigate what could be causing them, I tried many things (all possible settings, nvidia control panel settings...) no luck, downloaded GPU-Z and decided to monitor it.
Then I saw that the bus interface is running at PCIe x1 3.0 instead of the supported x16 3.0, I tried the render test and playing but it stays at x1 3.0.
I've been reading some threads about this but I cant get anything clear.
Already tried: Bios Settings, Power Settings at Maximum Performance, Driver Update with clean install, Removing the card and installing it again.

I have to add that I dont have those performance problems with all games, Witcher 3 works fine for example, but I dont know what to do anymore and it might be related to the way the games use the bus bandwidth?

My specs:
  • Motherboard B150M-d3h (I've checked manual to see if i installed it in the wrong place and it is installed in the x16 slot)
  • EVGA GTX 1070
  • 16 Gb ram ddr4
  • i5 6600 (which may be causing bottleneck)
  • x2 Sata SSD x1 Sata HDD (I've read that sata could be the issue?)
  • w10
Any help is greatly appreciated and sorry for my bad english.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts