Question Graphics Envy 15t k100

Lutfij

Titan
Moderator
The image you've linked shows that the display on your laptop is faulty or that the replacement units weren't up to par with quality. If the GPU failed, the issue would be seen on your external display and not just on your laptop's screen. You might want to see if your laptop has an BIOS updates pending for your particular model of laptop. Speaking of model, what is the model for your HP laptop? An SKU will help two fold.
 

Jackietools

Distinguished
Jul 26, 2009
384
0
18,790
3
HP Envy 15t k100 GOT55AV. That’s the original screen in picture and replacement showed same exact picture. I’ve gone thru 3 new LCD cables already. Only thing I can think of then is the cables are defective or wrong but they match an original replacement I bought last year to replace a worn one from rubbing on hinge. Maybe the contacts are dirty on the mobo but the inside is dust free. This is driving me crazy! Thanks
 

Jackietools

Distinguished
Jul 26, 2009
384
0
18,790
3
This is my daughters college PC. Last year screen started flickering with hinge movement so new cable fixed it for a year. It started again and old screen had a distorted picture when I replaced cable again. Figured it was screen so I bought 2 and had to return them. The pictures were good but all edges had dead spots. The newest one shows full screen but is washed out with very fine vertical bars showing. I switched back to original screen which I thought was totally dead but it now shows same exact picture as seen in photo and same as the newest screen. I’m trying to narrow it down but seem to be going in circles. Thanks
 

Jackietools

Distinguished
Jul 26, 2009
384
0
18,790
3
I did reset BIOS to defaults yesterday and am pretty sure it is up to date. I’ll check again tomorrow. Also another strange thing is battery no longer shows as being in laptop and will not charge. I also noticed time zone was changed as if CMOS battery is dead?
 

ASK THE COMMUNITY

TRENDING THREADS