Question GTA 5 Running Not good on High end PC

kubacs

Prominent
May 7, 2018
71
0
640
4
So i play GTAV with mods and visual mods and im not getting very well performance. I play on High-Ultra settings on GTAV and i play with mods and NaturalVision Visual Mod. With all of these mods i get like 30-45 FPS and constant stutters. I need help with this.



My Specs
CPU: i5-4670K
20GB RAM
GPU: MSI Aero GTX 1080 8GB + Overclocked it myself
Motherboard: Asus z87-k
Storage: 250gb ssd x2 (one is for windows and the other for good games like gtav, thats where mine is installed on the ssd)
Storage : 1TB HDD
Storage : 2TB HDD

Please help me out with this.
 

DSzymborski

Illustrious
Moderator
So i play GTAV with mods and visual mods and im not getting very well performance. I play on High-Ultra settings on GTAV and i play with mods and NaturalVision Visual Mod. With all of these mods i get like 30-45 FPS and constant stutters. I need help with this.



My Specs
CPU: i5-4670K
20GB RAM
GPU: MSI Aero GTX 1080 8GB + Overclocked it myself
Motherboard: Asus z87-k
Storage: 250gb ssd x2 (one is for windows and the other for good games like gtav, thats where mine is installed on the ssd)
Storage : 1TB HDD
Storage : 2TB HDD

Please help me out with this.
"All these mods" is kinda the complicating factor. Everything you add requires more power to drive it. The question is if vanilla GTA V underperforms what a vanilla GTA should be doing. If it's fine, it's likely too many mods or a poor mix of them. The CPU isn't overwhelmingly powerful and you also appear to have a FrankenRAM situation.
 
Reactions: Metal Messiah.

kubacs

Prominent
May 7, 2018
71
0
640
4
"All these mods" is kinda the complicating factor. Everything you add requires more power to drive it. The question is if vanilla GTA V underperforms what a vanilla GTA should be doing. If it's fine, it's likely too many mods or a poor mix of them. The CPU isn't overwhelmingly powerful and you also appear to have a FrankenRAM situation.
I have quite a bit of mods but on vanilla gtav i still only get like 50 fps with consistant stutters
 

Metal Messiah.

Notable
Mar 28, 2019
1,175
240
1,190
29
I have quite a bit of mods but on vanilla gtav i still only get like 50 fps with consistant stutters

Yes, games work perfectly well like battlefield 5 or 1 on ultra settings still getting like 90 -144fps
For GTA 5, try to reduce the in-game Video "GRASS quality" setting. So, I'm assuming all other games are running fine on your PC, expect GTA 5, but the performance is still not up to the mark ? RIGHT ? Your specs are OK, including your PSU model, in my opinion.

Please remove the OC from your GPU, for the time being. Also, make sure all the CPU cores are "unparked". Try some of these tips which I've mentioned below, just to narrow down your issue. Not sure whether this would be of any help, but give it a try

Have you tried looking into the POWER Management settings, i.e. Windows OS power plan, as well as the PCI Express setting, under the "Power Options", which is "Link State Power Management" ? Is it set to OFF ? What about your NVCP settings ?

Are you using the "Prefer Maximum performance" option, under the Power Management Mode ?

Also, I'm assuming the GPU is seated on the primary PCI-e x16 slot of your motherboard ? Should be, though you could try running a "PCI-Express Render test", via the GPU-Z tool, just to make sure the card is running at it's full potential. Just for an example. Click on the question mark, next to the BUS INTERFACE entry.



https://nvidia.custhelp.com/app/answers/detail/a_id/3130/~/setting-power-management-mode-from-adaptive-to-maximum-performance
 

kubacs

Prominent
May 7, 2018
71
0
640
4
For GTA 5, try to reduce the in-game Video "GRASS quality" setting. So, I'm assuming all other games are running fine on your PC, expect GTA 5, but the performance is still not up to the mark ? RIGHT ? Your specs are OK, including your PSU model, in my opinion.

Please remove the OC from your GPU, for the time being. Also, make sure all the CPU cores are "unparked". Try some of these tips which I've mentioned below, just to narrow down your issue. Not sure whether this would be of any help, but give it a try

Have you tried looking into the POWER Management settings, i.e. Windows OS power plan, as well as the PCI Express setting, under the "Power Options", which is "Link State Power Management" ? Is it set to OFF ? What about your NVCP settings ?

Are you using the "Prefer Maximum performance" option, under the Power Management Mode ?

Also, I'm assuming the GPU is seated on the primary PCI-e x16 slot of your motherboard ? Should be, though you could try running a "PCI-Express Render test", via the GPU-Z tool, just to make sure the card is running at it's full potential. Just for an example. Click on the question mark, next to the BUS INTERFACE entry.



https://nvidia.custhelp.com/app/answers/detail/a_id/3130/~/setting-power-management-mode-from-adaptive-to-maximum-performance

This is not really working i tried reducing settings and i even upgraded my GPU to a 1080tii had lying around and still others work fine but not gta v
 

Metal Messiah.

Notable
Mar 28, 2019
1,175
240
1,190
29
still others work fine but not gta v
If that's the ONLY game not working fully up to the mark, then I would rather put the blame on the Game itself/Engine, and/or the NaturalVision Visual Mod as well, assuming you want to play with this MOD installed. .Some graphical/visual mods can tank your performance.

Are you playing on 1080p, 2K, or 4K ?
 

kubacs

Prominent
May 7, 2018
71
0
640
4
If that's the ONLY game not working fully up to the mark, then I would rather put the blame on the Game itself/Engine, and/or the NaturalVision Visual Mod as well, assuming you want to play with this MOD installed. .Some graphical/visual mods can tank your performance.

Are you playing on 1080p, 2K, or 4K ?
im playing on 1080p and without the visual mod its still hitting like not that good fps
 
Feb 22, 2019
32
0
30
0
How is your GPU usage while playing GTA? I'm just curious since I have performance problems also with GTA V and my GPU usage is basically always under 50%.

I have tried to fix it and done some research, but right now I have just come to a conclusion that the game is just poorly optimized.
 

Satan-IR

Honorable
Apr 18, 2014
871
42
11,390
136
Mixing and matching RAM (if 20GB is sum of different modules) can have negative effects on system performance (if it's runs without stability issues in the first place).

You didn't mention the resolution you play at, as there's quite a lot of dfference between underperforming at FHD and underperfrming at higher resolutions, 4K for example. If the system (graphics card) performs within expected brackets in other games the problem is probably caused by the Mods.
 

Satan-IR

Honorable
Apr 18, 2014
871
42
11,390
136
I think OP has mentioned this before, after I asked him this same question. He is on 1080p, IMO.

Yes I missed that Metal Messiah, thanks.

I think I've seen similar issues before systems with high-end cards underperforming in GTA Veven at FHD.

The game itself seems not to be optimized well and the Mods are likely to compound the situation.

OP, you can do some trial and error reducing the eye candy visual features and see if any of them improve performance (without affecting visuals too much).

  • Lower water quality to normal.
  • Lower shadow quality to high or normal
  • Lower extended distance scaling to under 50%
  • Lower reflection quality.
  • Lower population density.
Another thing you can try is to turn MSAA off which improves performance more but has some visible effect on the visulas.
 
Reactions: Metal Messiah.

ASK THE COMMUNITY

TRENDING THREADS