Question Gtx 1050ti Black screen 640x480

Dec 30, 2021
2
0
10
0
Help, I bought a evga 1050ti (motherboard powered) from a friend about 2 weeks ago. About a week ago the screen went all pixelated and froze. I hard restarted the pc and my monitor said it was connected to dvi 480x640 but the screen was completely black. Windows makes noise, so it is booting up.
My old gpu is a gtx 580 which is still working and giving me an output. Every now and then the 1050ti works for a full session until the pc is turned off, there is no performance difference in the 1050ti from now and before this calamity. The 1050ti is in brilliant condition and the fan still spins when it is on. I have taken the 1050ti apart and it looks good, no visa le issues. Yes I have latest drivers, yes the cables work (I use the same for the 580).

Specs are:
Ryzen 7 3700x
32gb corsair vengeance (is correctly seated)
Gigabyte a520m
500gb Nvme M. 2 (boot)
1tb hdd
500gb hdd
EVGA 1050ti (motherboard powered)L
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

You forgot to mention the make and model of the PSU and it's age. BIOS version for your motherboard? Did you use DDU on the platform prior to replacing the RX580 with the GTX1050Ti? After DDU, did you manually install your GPU driver with the latest version in an elevated command?
 
Dec 30, 2021
2
0
10
0
Welcome to the forums, newcomer!

You forgot to mention the make and model of the PSU and it's age. BIOS version for your motherboard? Did you use DDU on the platform prior to replacing the RX580 with the GTX1050Ti? After DDU, did you manually install your GPU driver with the latest version in an elevated command?
The psu is an aerocool 500w I bought in May. Bios version is up to date (can't remember number but it was equal to the one shown on gigabyte page)
Yes I did the stuff with ddu, I followed some other threads on here for instructions
 

ASK THE COMMUNITY

TRENDING THREADS