[SOLVED] Hard drives in disk drive enclosure randomly disconnect/drop

Sep 20, 2021
62
1
35
0
I have a 4-bay 3.5" external HDD enclosure that connects via USB-C to my Windows 10 PC.
It has been reliable until recently, when randomly, I would "lose" one or two of my disk drives - they would literally just disappear as if they have been disconnected.
It is not necessarily the same disk drives either. Usually, it is disk 4, but sometimes it can be disk 2, or disk 3, and it can also be more than one disk, e.g. disks 2 and 4 can disappear. I don't think I've had a situation where they all disappeared yet.
Rebooting the PC temporarily fixes the problem, but it would randomly do it again, perhaps after a day or two, sometimes up to a week.
Does anyone know the reason for this? I initially suspected disk failure, but CHKDSK doesn't point to this and it's not always the same disk losing connection.
 
randomly, I would "lose" one or two of my disk drives
i've had a couple go bad in the past.
some 3rd party docks and some external drives where removing the drive from it's dedicated enclosure would allow the disk to function fine again.

as random as the issue is between different disks you know that it is not the actual drives failing.

you can try a different USB cable, some have issue with staying firmly connected over time.
or you can just contact the enclosure manufacturer and initiate an RMA.
 
randomly, I would "lose" one or two of my disk drives
i've had a couple go bad in the past.
some 3rd party docks and some external drives where removing the drive from it's dedicated enclosure would allow the disk to function fine again.

as random as the issue is between different disks you know that it is not the actual drives failing.

you can try a different USB cable, some have issue with staying firmly connected over time.
or you can just contact the enclosure manufacturer and initiate an RMA.
 

ASK THE COMMUNITY

TRENDING THREADS