[SOLVED] Having trouble with HDMI port on graphics card

Dec 25, 2021
2
0
10
0
Here's the run-down. I just got myself a brand new Nvidia GeForce GTX 1650 low profile for my HP Compaq elite 8300 running an i5-2400. I previously had an Nvidia GT 1030. I put the 1650 into my PC no problem, plugged my HDMI cable from my monitor into the HDMI port on the Video card. I turn on the Pc and I get a "No signal" error message. I proceed to plug my HDMI cable in and out of the port and tried to get the PC to recognize the HDMI port as a Display for an hour. No dice. I then Put my old 1030 into my Pc and uninstall its old drivers. I plug my 1650 in and again no dice. This time, I plug my VGA cord into the VGA slot in the motherboard and turn on my pc. Finally, I get a response and I'm taken to my desktop where I go to check if the Display adapters on the device manager read my 1650 and it doesn't but it reads the Intels HD graphics. Basically, The HDMI port on my graphics card isn't being read by my PC. I need to be able to tell my PC to switch from reading the VGA to HDMI. I just got This GPU today and Any suggestions would really help me out. Thanks.
 
Dec 25, 2021
2
0
10
1
Have you checked your graphics card is being shown?

1) Go to: device manager > display adapters and see if your gpu shows up. If it does, then make sure to enable it. If it is shown, go to: Windows settings > Display > Advanced display settings > and in the drop down menu, (which says something along the lines of display adapters,) press your graphics card and you should be good to go.

If that doesn't work, make sure the 1650 works in another machine on HDMI, you have astablished it works, but not if the HDMI isn't, so switch out your cable, monitor and machine to eliminate as many components as possible. Don't forget to take time with the troubleshoot.

Good luck!
 
Dec 25, 2021
2
0
10
1
Have you checked your graphics card is being shown?

1) Go to: device manager > display adapters and see if your gpu shows up. If it does, then make sure to enable it. If it is shown, go to: Windows settings > Display > Advanced display settings > and in the drop down menu, (which says something along the lines of display adapters,) press your graphics card and you should be good to go.

If that doesn't work, make sure the 1650 works in another machine on HDMI, you have astablished it works, but not if the HDMI isn't, so switch out your cable, monitor and machine to eliminate as many components as possible. Don't forget to take time with the troubleshoot.

Good luck!
 

ASK THE COMMUNITY