HDD Raid0 with OS on SSD


Jul 21, 2010
Hi everyone,

I seem to have become a little stuck with configuring my current Hard Drive solution; after finding vague or
conflicting advise from around the web, im hoping that there's others out there that can put my mind at ease
or at least point out the error of my setup.

Here is my current new build:

O.S: Windows 7 64-bit Professional edition
CPU: Intel i7 930
Mainboard: ASUS P6X58D-E
Optical Drives: Samsung Blu Ray (SATA)
Storage: Kingston V+ 128gb SSD (SATA)
500Gb Seagate Barracuda 7200.12 HDD (SATA)
500Gb Seagate Barracuda 7200.12 HDD (SATA)

AIM : Im looking to have the Kingston SSD running the O.S and a few other apps whilst the 2 Seagates would be
in a RAID 0 [Striped] setup for gaming and general data storage.

Attempt 1: kind of worked - I setup the SSD in BIOS to (AHCI) mode and installed the OS, later adding the
raid0 via the Disk Management in windows. I was later lead to believe this was software raid and would not be
effecient since the cpu has to do all the work, so should use the raid controller on the southbridge instead...

Attempt 2: so back in the BIOS I set SATA config to (RAID), after exiting BIOS the Intel Matrix Storage manager
window appears so I jump in and create a new Raid0 volume using JUST the 2 Seagates - the SSD was left as
non-raid disk. The P.O.S.T kept blue screening at the windows logo so i just decided to reinstall it - again choosing to install on the Kingston SSD.

Everything now appears fine in windows, Disk Management shows Disk1 as the SSD and Disk0 as the new 1gb drive

I can't get over the feeling that since all the SATA ports are running in raid mode, that the Intel ICH10R controller will not be handling the independent SSD correctly or blocking TRIM commands?
A quick run of 'HD Tach' on the Seagate volume shows average read speed of 210MB/s


Jun 26, 2009

I have an ASUS mobo (P6T Deluxe V2) and a Patriot Tech M28 SSD with the latest firmware, as well as a 2 drive RAID (striped) array. Notes on the web indicate that if you open a CMD window (right click command prompt and select Run as Administrator) and run the following command: fsutil behavior query disabledeletenonotify and press enter. If it returns with a "0", then trim is active on your system. I'm pretty sure that I read (in more than one location) that if RAID was enabled in the BIOS then TRIM wouldn't function on an SSD.

On my system I had IDE Config set to AHCI (using win 7 drivers), (I also set PNP OS to YES in the BIOS (for non-bootable devices), and installed the OS on the SSD. Once windows was up and running, I installed the Intel Matrix software (available from ASUS, or probably on the DVD that came with your board), and setup a RAID (striped) Array for my two WD drives. Selecting the first drive a gives you the option to add another device, configure and name the array.

On my system, fsutil behavior query disabledeletenonotify returns a "0".

Everything work GREAT!!!

Hope this helps.



Feb 26, 2010
Download and run the latest Intel Rapid Storage Technology driver (9.6) here.

It supports TRIM for an SSD in RAID, but not part of an array, like yours!

You are good to go, sounds like you did alot of research before hand. Kudos.

So you now know you should have set up the BIOS to RAID, set the arrays, THEN installed WIndows 7. We learn by our mistakes, and I did!


Jul 21, 2010
Thanks for the replies Mikey and foscooter.

mikey5802: That fsutil command you mentioned was the one I was originally checking with - its a good indicator of whether the drive is TRIM capable but I don't think it can prove its actually working (controller may still not pass on the requests to the drive).. I guess only a lengthy benchmark could show for certain :sweat:
So you setup all of your drives in AHCI mode and let the Matrix controller build the raid in windows? hmmm sounds like the smart way of doing it, since i expect its still the firmware handling it rather than the software. I'll keep this in mind if I do a rebuild

foscooter: Its funny you mention the Intel Rapid Storage driver since I installed it just before seeing your post - heard its essentially the latest Intel® Matrix controller (just with a new name) and as you say - now handles TRIM correctly in RAID.

Well I feel a lot more confident that its working as it should be now after updating to Intel® Rapid Storage Technology, so I'll see how it goes

the following article helped clarify it a little more as well:

Similar threads