Question Headset Help

Jun 6, 2019
18
0
10
0
Hi, for the past few years I have had the Logitech G430 headset which also had problems when I built my new computer. I have recently made a completely new build and unfortunately I've had many problems with the headset. Just today I have got a new headset which is the Hyperx Cloud Alpha. The only problem is that I cannot get it to work properly. To begin with, i',m not sure whether it should be plugged into the front of the computer or the back although both recognise it as 'speakers' rather than what my old computer use to say which was the headsets name. My problem is that the microphone quality is extremely low and does not work at all. It keeps cutting out all the time and doesn't pick up my voice up properly. This was also a problem with my G430 on my new PC. To fix this I had to plug the microphone into the USB adaptor which it came with and then the headset. Can anyone help me please? thank you.

RTX 2060
MSI X470 GAMING PLUS
2600X
NZXT H500
 

hang-the-9

Titan
Moderator
If the mic is not picking things up and you had the same issue before, sounds like you either have an issue with your mic jack on the computer or you are keeping the mic too far from your mouth. My Windows 10 system has no issues seeing the Alpha as a headset. Are you using the single jack or the adapter and separate headset and mic inputs to the computer? Make sure you have the jacks in the right ports and that the audio card options are set properly. No way to really know what the issue may be without actually being there and seeing how you have things connected and configured.
 

ASK THE COMMUNITY

TRENDING THREADS