Question HELP!!!! I'm Getting worse frames on an external monitor

Dec 17, 2021
26
1
35
0
Hey guys I'm running into an issue while im getting a warranty repair on my graphics card so I'm connecting my laptop to my monitor. Only problem is I'm getting significantly worse frame rate on the external monitor then when I am just running the laptop itself. It's an Asus rug strix advantage edition with a 6800m and a 5900 HX. I do have it set up to only display on the second screen any suggestions that would be great.
 

Aeacus

Champion
Ambassador
If both would be with different reso, e.g laptop with 1080p and monitor with 1440p, then the FPS drop would be easily explained. However, i know no case, where 20 Hz diff would matter a lot in terms of FPS.

Still, make and model of your external monitor is?

Also, what port on your laptop you're using (DP or HDMI) + what the port version is? And what version the display cable is, that you're using?

I'm getting significantly worse frame rate on the external monitor then when I am just running the laptop itself.
"Significantly worse" is vague. What the exact FPS diff, between the laptop screen and external monitor is?
 

Aeacus

Champion
Ambassador
Well, only thing, that i can think of, is that your Asus monitor is G-Sync one, with good compatibility with Nvidia GPUs. However, GPU in your laptop is Radeon and that difference may cause the FPS drop issue. Other than that, i know of no other reason why there would be 30-50 FPS diff between the two.

Might want to try and disable some features of the Asus monitor (e.g ELMB Sync, Adaptive Sync, HDR) to see if it helps. Also, try running it without 280 Hz OC, instead at 240 Hz or 144 Hz.
 
Dec 17, 2021
26
1
35
0
Well, only thing, that i can think of, is that your Asus monitor is G-Sync one, with good compatibility with Nvidia GPUs. However, GPU in your laptop is Radeon and that difference may cause the FPS drop issue. Other than that, i know of no other reason why there would be 30-50 FPS diff between the two.

Might want to try and disable some features of the Asus monitor (e.g ELMB Sync, Adaptive Sync, HDR) to see if it helps. Also, try running it without 280 Hz OC, instead at 240 Hz or 144 Hz.
Yeah I currently have it set to 240 and I never use g sync or free sync
 

ASK THE COMMUNITY