Question Help needed with GPU drivers!

Oct 22, 2020
3
0
10
0
I have pc with:

Ryzen 5 3600
B570 A-pro mobo
Sapphire nitro + 5700 xt
16 gb ram
coolermaster 750w psu

The thing is I am having a problem for a long time with my pc. Without [manufacturer's] gpu drivers being installed, it works fine. When I install the drivers, after some time the pc freezes for a moment, then the monitor screen blinks and this goes on leading to blue screen error where the error code is atikmdag.sys.
I have literally tried everything. I mean everything. Have tried every version of gpu driver. Have installed new window 5 6 times, all in vain.
Here is the link to the video that I made to show this problem:

View: https://imgur.com/a/H2C05mb


Can anyone help please?!
 
Last edited:
Oct 13, 2020
39
7
45
3
by what i see you are trying to install an old driver. what version is it? try using some software that cleans driver remains and then try installing again. also download a driver version with WHQL in the name just to be sure its a well tested version.and one more thing, turn off the antivirus during installation, its happens rarely but it may be blocking something it shouldn't.
 
Oct 22, 2020
3
0
10
0
by what i see you are trying to install an old driver. what version is it? try using some software that cleans driver remains and then try installing again. also download a driver version with WHQL in the name just to be sure its a well tested version.and one more thing, turn off the antivirus during installation, its happens rarely but it may be blocking something it shouldn't.
Its like I have tried every version of driver. I have used DDU and and cleanup utility and then installed fresh new drivers downloaded from amd official website. And still the problem persists. When I uninstall the drivers, the pc works absolutely fine. But whenever I install the gpu drivers, this problem comes back always.
 
Oct 13, 2020
39
7
45
3
see if something like this matches your case


also try doing the following old school method
right click on "this pc" and select "properties"




choose device manager and find the entry for your card



right click on the card and choose properties and this screen you choose "update driver"



after that you pick "browse my computer for drivers" and then you indicate the AMD folder where the driver was unpacked when you tried to install it

windows should find the driver files in there and install them without going through the radeon software and that may solve your problem.
 
Last edited:

ASK THE COMMUNITY