[SOLVED] HELP!! New build troubleshooting

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
I was previously considering the memory controller, and it's also considered by Gigabyte so that must be it. The memory controller is part of the motheboard so a RMA should solve it.

Additional suggestions?
1. Cleaning the RAM slots may help...
2. maybe tweaking the BIOS for RAM speeds and power increase or decrease, timings, depending on options available in the BIOS. https://www.hardwaresecrets.com/understanding-ram-timings/
3. If you have a voltmeter, check the BIOS battery voltage. Anything under 3 volts and replace it for optimal BIOS functionallity. The battery does much more than keep the BIOS clock on time and when the clock goes the battery is already dead so check that... and that applies even to new batteries as they can be already be dieing when you buy them so don't think a relatively recent motherboard is safe from the possibility of having a weak battery.

What are the signs of CMOS battery failure?
https://www.bayt.com/en/specialties/q/10887/what-are-the-signs-of-cmos-battery-failure/

Weak CMOS Battery May Prevent Your Computer from Booting!
https://steamcommunity.com/discussions/forum/11/618460171318429760/
 

srbecker58

Prominent
Sep 12, 2017
39
0
540
2
Isnt the Memory controller in the newer processors built in? If so, it could still be a CPU issue, right? Anyways, I have a new motherboard on its way, I will try that out. My question in regards to the new motherboard is, do I throw all 4 sticks in right away and see if it boots?

I have been playing around and doing more trouble shooting this evening and here is what I have concluded/confirmed.

1. It ran for 3 months with 4 sticks of memory, but all of the sudden it decides it no longer wants to even boot with 4 sticks (odd). I did however do driver updates and BIOS is now currently on F22

2. It will not do ANYTHING with 4 sticks of RAM. I cant even get into BIOS with 4 sticks. I can use any combination of 2 sticks in either the A or B slots (dual channel mode)

3. Turned XMP on with 2 sticks in, restarted, ran Prime95 and it is stable. It shows timings that match the RAM 15-15-15-39

4. I turned XMP on, powered down, put the additional 2 sticks in, powered up, it freezes, restarts, freezes with black screen with CPU light lit on motherboard. I removed 2 sticks, it restarts and gives me a "The BIOS has been reset, press ok to clear CMOS" or something along those lines.

5. I turn XMP back off, the timings change in the BIOS from above to 16-16-16-39, which does not match that labeled on the RAM...

6. Reboot with 2 sticks, runs fine, passes Prime95 with no issues and seems stable.

7. Put 4 sticks back in, no boot, CPU light is lit on the motherboard.

All sticks check out, all sticks work in pairs or individually. So this leads me to believe it is the board more than likely due to the odd issues with the BIOS and the failure to read the RAM properly with XMP turned off. Should I be running the RAM with XMP on or off?

There is a possibility that it is the memory controller in the CPU, which at that point, if the motherboard RMA doesnt fix the issue, the CPU is next. Then replace the RAM with 2x16gb instead of 4x8gb as a last resort.

Does that all make sense and seem like I am taking the proper steps?
 
Right! The memory controller is integrated in the CPU.. but I doubt the CPU or motherboard is defective.

# 3 & 4. “The BIOS has been reset” with the memory timings getting changed, seems to indicate a BIOS issue, but it could be something else… this thread talks about the BIOS reset message, many people added their solution and the causes were quite a few but the most common seem to be BIOS corrupted settings, bad power switch connection, and GPU issue.

Won't boot unless clear CMOS every time, not battery
http://www.tomshardware.com/forum/286558-30-boot-clear-cmos-time-battery

#5. Leave XMP enabled but try different profiles… if none works try it with XMP disabled.

#1, #2, #6, #7. Your RAM is DDR4 2400 (PC4 19200), Double Rank (2Rx8) and these Pages say the Ryzen 5 1600 supports two RAM modules of DDR4-2400 Mhz or 4 modules of DDR4-1866 Mhz Double Rank RAM but it doesn’t include the 4 modules of DDR4-2400. So it may be a RAM compatibility issue… I would see if the BIOS allows slowing the RAM speed to 1866 Mhz. Further research on the Memory Rank configuration for four modules may be necessary but first try a RAM speed reduction in the BIOS.

https://en.wikichip.org/wiki/amd/ryzen_5/1600
https://www.oempcworld.com/support/singlevsdualram.html
http://www.cpu-world.com/CPUs/Zen/AMD-Ryzen%205%201600.html
 

srbecker58

Prominent
Sep 12, 2017
39
0
540
2
Ahhhh, you sir are a genius!!! I changed the speeds manually to 1866 (XMP off), installed the 2 additional sticks and it booted right up. I ran Prime95 for roughly 20 minutes (long enough to pass the first test) and it ran stable with good temps. That seemed to have done the trick. Now, for more questions. Knowing this...

1. Do I run with it as is?
2. I already requested a motherboard RMA, do I try the new one just for the heck of it?
3. Do I see about swapping my 4x8gb dual rank memory kit for a 2x16gb dual rank memory kit to utilize higher speeds?
4. Do I try bumping up to 2133 and see if it is stable there?

Any other suggestions you may have?

EDIT: UGH, still having issues. Currently running with 4 sticks of RAM at 1866 and it seemed stable, however I checked on it by remoting in once I got to work and sure enough it restarted. Stop code 03b, SERVICE_EXCEPTION caused by driver TCPIP.SYS. As I was remoted in, I checked for windows updates and during the download process, it rebooted on me again and never came back online, so I can only assume it blue screened again. I am hoping it is again caused by the TCPIP.SYS driver, so hopefully this is just an unrelated BSOD, however if not, it looks like I am still troubleshooting!
 

gosubuilder

Prominent
Apr 21, 2017
158
0
760
28


from skimming through this whole thing... why not RMA the ram?
 

srbecker58

Prominent
Sep 12, 2017
39
0
540
2
Night Owl, the RAM was RMA'd once already. This current set shows no errors in tests unless I have all 4 sticks installed, and even then, errors only appear if the test continues. Most of the time the test will freeze or reboot the computer with 4 sticks installed. RMA would only get me like RAM, which does me no good. I need to either run with 2x8gb or cut my losses with what I have and get 2x16gb. Either way, I am 100% stable now for 24+ hours and that includes any test I could throw at it. I really think its the CPU cant handle the speeds/times or the RAM with 4 sticks, even clocked down.
 

It seemed to god to be true… but at least we’re on the right track and to achieve stability it may take further RAM setting adjustments in the BIOS… such as lowering timing and increasing voltage in small increments towards the stock settings for 1866 mhz RAM.. which is DDR3 and that type of RAM uses different voltage and timing, so you may have to stick to DDR4 settings so an overclocking guide for DDR4 may provide the best information to change BIOS settings but in the opposite direction from overclocking. We need a guide to do this right because I don’t mess with RAM timings or voltage so I don’t know much about the proper adjustments but I know they have to be very gradual and I would only be guessing if I mentioned numbers so a RAM overclocking guide may help and so would checking some related threads I linked below.


The TCP/IP (Transmission Control Protocol/Internet Protocol) driver is the Internet connection driver and it is the language a computer uses to access the internet and it’s crash can be caused by an open number of internet access programs, so memory may be involved… that takes us back to the unstable RAM issue. It can be caused by BIOS corruption since the BIOS loads the system drivers when the computer starts, so clearing the BIOS may be necessary.

How To Fix Tcpip.sys Blue Screen Errors (BSOD)
https://www.solvusoft.com/en/files/bsod-blue-screen-error/sys/windows/microsoft/april-2011-security-release-iso-image/tcpip-sys/

TCP/IP
https://searchnetworking.techtarget.com/definition/TCP-IP

TCPIP BSOD
http://www.tomshardware.com/answers/id-2577825/bsod-tcpip-sys-driver-irql-equal.html

Memory (RAM) Overclocking Guide - DDR3 (For reference only)
https://www.masterslair.com/memory-ram-overclocking-guide-ddr3

DDR4 RAM overclocking 101 guide
http://www.overclockers.com/forums/showthread.php/785102-DDR4-RAM-overclocking-101-guide

DDR4 Memory overclocking guide
https://goo.gl/zeWM5j

How to increase RAM speed (the opposite in your case)
http://www.tomshardware.com/forum/273956-30-increase-speed-bios

Need help optimizing 1866 mhz RAM through BIOS
http://www.tomshardware.com/answers/id-2893734/optimizing-1866-mhz-ram-bios.html
 

Can you RMA and exchange your four modules for a 2x16 GB kit.?.. If according to both the wikichip.org/ and cpu-world pages the Ryzen 5 1600 supports 2400 Mhz RAM in two modules/two slots, that would be the ideal solution. To run 4x8GB at 2133Mhz it would have to be Single Rank and your's is Double Rank... See the AMD’s officially-supported DRAM configurations table
https://community.amd.com/thread/217782

You said it ran stable with 4x8GB modules for a few days but other users have ran their computers with incompatible RAM before and for longer periods of time so the fact your's ran for days is nothing new.
If you can't exchange it, maybe you could sell the 4x8GB online... you may have to lower the price a bit.


AMD Shares Details on Ryzen DDR4 Memory Support and Upcoming AM4 Updates
https://www.techpowerup.com/231518/amd-shares-details-on-ryzen-ddr4-memory-support-and-upcoming-am4-updates

Tips for Building a Better AMD Ryzen™ System.. ram issues and ideas to help.!
https://community.amd.com/thread/217782
 

srbecker58

Prominent
Sep 12, 2017
39
0
540
2
Well, computer is still crashing on me. I have replaced the motherboard, updated the BIOS, ran memtest86 overnight with no errors. I have 2 things left to replace and that is the CPU and PSU, starting with the PSU as I have had a couple restarts with no errors or BSOD's, just plain restart... That being said, none of my blue screen errors are of any use. They all say the ntoskrnl.exe is the cause but always have a different explanation such as MEMORY _MANAGEMENT_ERROR, IRQL_NOT_EQUAL and a few others that I can recall right now.
 
MEMORY _MANAGEMENT_ERROR, IRQL_NOT_EQUAL The cause was bad motherboard... in your case with a new motherboard, the possible cause could be either the CPU (memory controller) or the PSU. Power issues can cause apparent hardware errors since every component runs on power the PSU feeds.

You did replace the PSU with a 700 watt PSU from a spare work computer,...right? and that other PSU didnt change anything.... but did you leave it on long enough to get a reboot?, or did you go back to the previous PSU?

See if any advice or CPU testing software helps determine a CPU issue. I can't specify a particular tool but seems that AMD System Monitor would be a good one to start with.

SOLVED Stopcodes "Memory Management" "IRQL less or not equal"
http://www.tomshardware.com/forum/id-3507598/stopcodes-memory-management-irql-equal.html

AMD System Monitor
https://support.amd.com/en-us/kb-articles/Pages/AMDSystemMonitor.aspx

AMD processor diagnostic tools, tests, etc.
http://bit.do/amd-cpu-testing-advice-and-software
 

srbecker58

Prominent
Sep 12, 2017
39
0
540
2
Thanks Chicano! You have been there this whole process and always offering advice and possible solutions. It is very much appreciated!

I did try a spare PSU from work, but that was when I was still troubleshooting the RAM issue which turned out to be that my CPU just cannot run 4 sticks of dual rank memory at 2400. Solution to that was run 2 sticks in dual channel at 2400 and my boot issues were resolved, but I still get random BSOD's. The only 2 things left are CPU and PSU and I am in the process of doing a PSU RMA right now.

I dont think it is memory at this point because I was able to pass multiple memtests including one that was 8 hours long and 4 passes.

It very well could be my PSU as I dont think the testing at work was long enough to verify it was a PSU issue or not.

I think over the hardware swaps and extensive testing we can rule out the following:

- Motherboard
- Memory
- Drivers

Which leaves me left with:

- PSU
- CPU
- GPU (maybe I should try running on the on board graphics for a day or so and remove my GPU?)
- Windows
 
No problem srbecker58... my only disappointment is not being able to help as efficiently as I hoped.

The GTX 1060 GPU may bottleneck very slightly with the Ryzen 5 1600 (11% while 10% is considered a bottleneck)... that according to the Bottlenecker website, but 1% is not enough to cause the crashes. And using the computer onboard graphics can't do better though it may at least behave differently and hopefully enough to help determine a GPU performance issue.

What I'd suggest is running HWiNFO64 on Sensors only, and taking screenshots, one while under the conditions that cause the crashes and another screenshot of the sensors report while the PC is running normally and stable. Next, save the report to paint.png format > upload the images to an image sharing website, links below.

Take a HWiNFO Sensor Report > use the blue arrows Expand icon on the bottom > this will put every page of the report on the same display full screen > Press the Print Screen key > Open a Paint file > Paste the screen capture > upload the image to your favorite image sharing website, and post the image links here.


https://postimages.org/
http://tinypic.com/


 
On the BSOD Errors; if changing the PSU doesn't solve them, see the errors explained on the bsodanalysys blogspot... copy and paste each error on the blogspot search bar (top left), and see if solutions for your system errors are found there, and if their suggested solutions coincide.


CRITICAL_PROCESS_DIED
ATTEMPTED _EXECUTE_OF_NONEXECUTE_MEMORY
REFERENCE_BY_POINTER
SYSTEM_SERVICE_EXCEPTION
DRIVER_IRQL_NOT_LESS_OR_EQUAL
ERQL_NOT_LESS_OR_EQUAL


http://bsodanalysis.blogspot.com/2013/08/
https://bsodanalysis.blogspot.com/search?q=CRITICAL_PROCESS_DIED%2C+ATTEMPTED+
 

srbecker58

Prominent
Sep 12, 2017
39
0
540
2
Well, to put this post to rest finally, after months of error free running, zero restarts, zero BSOD's and normal CPU usage, my problem is resolved and my PC is stable.

The resolution was one of the following (not exactly sure which one or maybe a combination of both).

  1. I RMA'ed the CPU with AMD per their recommendation
  2. I reformatted the C: drive and then reinstalled windows (just to be sure everything was fresh)
Since then I have had zero problems!!!!
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS