Question Help with a weird possible GPU issue

Feb 18, 2020
6
0
10
0
So I’m in a weird situation, I was using my PC one day and Im not sure if it randomly shut off or if I accidentally pressed the case power button but my pc turned off and would not display to my monitor upon turning it back on everything seemed to be working (case fans, cpu fan) except the USB ports however the Ethernet port did light up, I tried troubleshooting by removing my gpu and starting my pc (even though my mobo doesn’t have integrated graphics) I noticed that when I turned my pc on without the graphics card in that after awhile I would receive power to my USB ports after a maybe 30 seconds after pushing the power button, but when the gpu is in i get no power to usb at all. THIS IS A FRESH RMA gpu btw no Im literally dumbfounded I tried everything from cleaning ram to removing cpu to check for bent pins
Help please
 
Feb 18, 2020
6
0
10
0
Have you checked the cable that connects the Case's USB ports to the mobo to make sure it's not bent or installed incorrectly?
Yes I have rebuilt the system from scratch about 3 times. This issue is killing me because it’s so bizarre I feel like it could be my mobo or psu
 

Newtonius

Respectable
Yes I have rebuilt the system from scratch about 3 times. This issue is killing me because it’s so bizarre I feel like it could be my mobo or psu
I take it these are USB 3.0 USB ports - have you also tried reinstalling the mobo drivers? Some mobos have a dedicated 3.0 USB driver, perhaps it got corrupted since it somehow works on and off.
Also try updating the motherboard BIOS too while you're at it.

If none of that works, it's most likely you have a bad board.
 
Feb 18, 2020
6
0
10
0
I take it these are USB 3.0 USB ports - have you also tried reinstalling the mobo drivers? Some mobos have a dedicated 3.0 USB driver, perhaps it got corrupted since it somehow works on and off.
Also try updating the motherboard BIOS too while you're at it.

If none of that works, it's most likely you have a bad board.
Im unable to do any of those things because I have no display and my mobo doesn’t have dedicated graphics but I’m hoping it’s a bad board and not my gpu
 

ASK THE COMMUNITY