Question Help with Digital audio setup using a logitechz903 5.1 sound system on an asus Maximus ix formula

domjam

Honorable
Jan 19, 2014
173
0
10,680
0
Hi I'm trying to setup 5.1 surround sound for my computer using my Logitechz903 using the digital connection.. up until now iv been using normal audio connection for it and it works but only if I disable the effects on the unit.ie 3d sound,4.1 etc otherwise sounds are missing from things in games and movies but having it disabled makes the sound very flat. I was told to use a optical connection but I never used this before and im having problems with it. I have connected the optical cable from the Logitechz903 to my ASUS maximus IX formula motherboard. and i have switched the Logitechz903 box to mode 4 (optical) iv run the test on the unit itself and everything is working yet im not getting any sound at all on the computer when trying to test it using the Realtek HD audio manager. If i go into supported formats in windows 10 device properties under sound settings, I am able to test and hear all the sample rates (192.0khz being the highest) but only from the 2 side speakers. Under encoded i have the options that i can tick for DTS Audio, Dolby Digital and Microsoft WMA Pro Audio but the test button is always grayd out and under sound control panel playback Realtek Digital Output has a green tick next to it but I can only click properties. Configure and Set Default are grayed out. what am I doing wrong?
 

Satan-IR

Honorable
Apr 18, 2014
833
37
11,390
135
Have you configured the sound device to use 5.1?

Right click on the speaker in the taskbar, click on playback devices and scroll to the default device (one with the green tick), highlight it and press configure. There you should have modes like stereo, quadrophonic and surround like 5.1 and 7.1 etc.
 

domjam

Honorable
Jan 19, 2014
173
0
10,680
0
Have you configured the sound device to use 5.1?

Right click on the speaker in the taskbar, click on playback devices and scroll to the default device (one with the green tick), highlight it and press configure. There you should have modes like stereo, quadrophonic and surround like 5.1 and 7.1 etc.
Thanks for replying but what you suggested is the same as what I previously stated in my post just another way of getting to that setting. "under sound control panel playback Realtek Digital Output has a green tick next to it but I can only click properties. Configure and Set Default are grayed out." any other sugestions?
 

Satan-IR

Honorable
Apr 18, 2014
833
37
11,390
135
Thanks for replying but what you suggested is the same as what I previously stated in my post just another way of getting to that setting. "under sound control panel playback Realtek Digital Output has a green tick next to it but I can only click properties. Configure and Set Default are grayed out." any other sugestions?
Yes I'm aware it's another way of doing it but it won't hurt if you directly tried it through the Windows to avoid any possible bugs/problems the Realtek code/GUI might be causing and not working properly.

Which Windows do you have?

Set Default should be greyed out if that device is actually "set as the default device", hence the green tick, but configure should work nonetheless. Configure being greyed out is weird.

Are you BIOS, chipset driver and sound/realtek drivers updated to latest versions provided by ASUS?
 

domjam

Honorable
Jan 19, 2014
173
0
10,680
0
Yes I'm aware it's another way of doing it but it won't hurt if you directly tried it through the Windows to avoid any possible bugs/problems the Realtek code/GUI might be causing and not working properly.

Which Windows do you have?

Set Default should be greyed out if that device is actually "set as the default device", hence the green tick, but configure should work nonetheless. Configure being greyed out is weird.

Are you BIOS, chipset driver and sound/realtek drivers updated to latest versions provided by ASUS?
O ok . well i cant do that as there is no playback option in the speaker icon on taskbar. i assumed what i did is exactlty the same as what you suggested just the method to get there was slightily different from yours. I,m running windows 10 and for me under my speaker icon on task bar there is no playback option. only volume mixer,sound settings, spatial sound, sounds or troubleshooting sounds and the only way to get to playback setting that you describe is either clicking sound setings then sound control panel or clicking the start menu then the gear icon that takes me to the sound window and clicking sound control panel in any case the configure and default button for Realtek Digital Output under the playback tab are grayd out. Only the properties tab is viewable. im already using the latest drivers for my Motherboard for bios, chipset and onboard sound. I,m lost as to why its not working.
 
Last edited:

Similar threads


ASK THE COMMUNITY

TRENDING THREADS