Question High CPU usage on Ryzen until opening task manager

Helicrom

Prominent
Dec 14, 2019
32
1
535
0
Hey guys, i saw already on many forums that other people had the same issue and most of them it was from a virus, i tried at first running some malvware and adwcleaner but nothing, then i made clean install windows and its the same.
When i open task manager my CPU usage is at least 50% usage then immediatly drops to 0-3% after that.
The processes that are doing the issue seem to be State Repository Service + Windows Explorer !
I tried restarting it as said in many forums and even disable it from run/msconfig/services but after few seconds it starts again..
Any suggestions?
  • Ryzen 5 2600
  • Win 10 Pro 64-bit 2004
  • Latest drivers on everything
 
That's not an issue. Mine goes to 24% when I open task manager on a 3900X.

Why would you think that this is a problem? You open Task Manager your CPU is working to open that and just go back to normal after a second.
 

Helicrom

Prominent
Dec 14, 2019
32
1
535
0
That's not an issue. Mine goes to 24% when I open task manager on a 3900X.

Why would you think that this is a problem? You open Task Manager your CPU is working to open that and just go back to normal after a second.
But mine is 50% + when i open it for a second and its caused by State Repository Service + Windows Explorer...
 
But mine is 50% + when i open it for a second and its caused by State Repository Service + Windows Explorer...
State Repository Service and Windows Explorer are both process of the OS. It's the same for me. It's the same for everyone.

You seems to believe that your CPU is always at 50% and it drops to 0-3% ONLY when you open task manager but that is false. Your CPU is at 0-3% before you open task manager and it's opening the task manager that makes the CPU go to 50% and come back down.

You do not have an issue or a virus. This is normal behaviors.
 
Reactions: Helicrom

Helicrom

Prominent
Dec 14, 2019
32
1
535
0
State Repository Service and Windows Explorer are both process of the OS. It's the same for me. It's the same for everyone.

You seems to believe that your CPU is always at 50% and it drops to 0-3% ONLY when you open task manager but that is false. Your CPU is at 0-3% before you open task manager and it's opening the task manager that makes the CPU go to 50% and come back down.

You do not have an issue or a virus. This is normal behaviors.
Okay, understood ! :D
Thanks
 

ASK THE COMMUNITY