• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question High CPU usage

Ompted

Honorable
May 31, 2015
25
0
10,530
0
I'm not sure if it's age or I might have messed something up. My games like Overwatch and TF2 have a hard time running on my PC after a few years. Overwatch was at 60 to 70 percent CPU and TF2 sometimes drops below 60 fps at times. I have a i7 4790k overclocked to 4.5 ghz at 1.229 volts stable. I have a 850 Watt power supply so im not short on power. Settings are as follows. CPU is constantly at 100% on some games and things like MC have bad memory dumps which it microstutters. Not sure entirely what's going on.

Intel Boost Technology: Enable
Turbo Boost Power Max: Unlimited
Turbo Boost Short Power Max Unlimited
Short Power Max Enabled
Turbo Boost Power Time Window: 1.000 Seconds
Processor Current Limit 1k A
Core Voltage: Static
Voltage:1.229 V
All cores set to 4.5 Ghz
Cache Voltage Mode: Adaptive
Cache Voltage: Default
Cache Offset: 0.3V
Processor Ratio: 40x
Temp under load is 80C stable

Other PC info.
PSU: 850 Watts
GPU: GTX 1070 SC
RAM: 16 GB DDR3
 

Ompted

Honorable
May 31, 2015
25
0
10,530
0
On idle when it's just running chrome, I hit about 15% to 25% CPU. Steam, discord, and WMI Provider Host seem to make up the majority of idle at 4%~ total. I watched my resources running through a open area. While there were spikes of mini lag, a insignificant micro stutter, it was present but none of my resources spiked hard.

Consistent 80%~ usage but never hit 100%. Highest temp recorded was 83 C, 70 C was the average. GPU was stable at 60% Usage (65C) and RAM was at 12.2 out of 16 GB. Lag was felt in intense moments, but never dropped below 60 FPS at high settings. Micro stutter was felt when entering new areas when it loaded as i moved through the map. Game is installed on a SSD. Tested on Destiny 2. No idea what's causing it to drop if it isnt being used fully.
 

ASK THE COMMUNITY