[SOLVED] How do I partition a 8 Gb disk safely?

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Nov 24, 2020
63
2
35
0
You can also do it without reinstall. But this requires creating bootloader on 500GB drive manually.

To create bootloader on 500GB drive, execute from elevated command prompt. Regular command prompt will give error on last step.
(if you get any errors, then stop immediately)
diskpart
list disk
select disk 1
list partition
select partition 2
(select 505MB partition)​
delete partition override
create partition primary size=500
format fs=ntfs quick
assign letter=H
exit
bcdboot c:\windows /s H:

After that shutdown and try to boot with only 500GB drive connected.
If all goes well, then reconnect 8TB drive, clean it, convert to GPT, partition and format it.

Thank you again for taking the time to help me.

My 500 Gb drive is a M2 drive, so I cannot connect a SATA cable. I tried disconnecting the 8 Tb drive with the 500 Gb selected as the first device selected to boot from and it did not boot.

I also tried setting the DVD as the primary boot device with the 8 Tb disconnected and the machine did not boot.

It will boot to Windows 10 if the 8 Tb is connected, even when the DVD is selected as the primary boot device (BTW, I have 2 DVDs connected).

So, do I connect the 8 Tb and follow the directions above?

Thanks again,
Andy
 
Last edited:
Thank you again for taking the time to help me.

My 500 Gb drive is a M2 drive, so I cannot connect a SATA cable. I tried disconnecting the 8 Tb drive with the 500 Gb selected as the first device selected to boot from and it did not boot.

I also tried setting the DVD as the primary boot device with the 8 Tb disconnected and the machine did not boot.

It will boot to Windows 10 if the 8 Tb is connected, even when the DVD is selected as the primary boot device (BTW, I have 2 DVDs connected).

So, do I connect the 8 Tb and follow the directions above?

Thanks again,
Andy
You have to get into bios and set it up so that your 500Gb disk shows up as disk 0, first boot device, otherwise anything you do will have the same result as now.

I think there are some mobos that can't boot from m.2 though but I might be wrong there.
 
Nov 24, 2020
63
2
35
0
You can also do it without reinstall. But this requires creating bootloader on 500GB drive manually.

To create bootloader on 500GB drive, execute from elevated command prompt. Regular command prompt will give error on last step.
(if you get any errors, then stop immediately)
diskpart
list disk
select disk 1
list partition
select partition 2
(select 505MB partition)​
delete partition override
create partition primary size=500
format fs=ntfs quick
assign letter=H
exit
bcdboot c:\windows /s H:

After that shutdown and try to boot with only 500GB drive connected.
If all goes well, then reconnect 8TB drive, clean it, convert to GPT, partition and format it.

Thanks again for helping me. A few things before I go ahead with the steps above:

The system will not boot into Windows with the 8 Tb disconnected.

ThHe 500 Gb drive is a M2 drive, not a SATA drive.

If the 8 Tb is disconnected, and DVD selected as primary boot device, and I put the Windows 10 (Home) DVD in the DVD drive, all I see is a blinking cursor.

So, can I go ahead as recommended above?

Thanks,
Andy
 
Nov 24, 2020
63
2
35
0
So, the Diskpart stuff did not result in any errors, but the system would not boot with the 8 Tb disconnected. So, I changed the primary boot device in the BIOS to DVD, disconnected the 8 TB and am now doing a complete (re-install) of Windows 10. Bummer. But I expect this to work. I appreciate everybody's help. Unfortunately, my understanding is that I can only assign 'points' (a.k.a. Best Answer) to one person. So I will choose the first person who suggested the clean installation.
 
Nov 24, 2020
63
2
35
0
It finally works!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! After I said I did not have a key when I installed Windows. But now a new problem, for which I will create a new thread in Storage.

PS when I did the reinstall, I had to indicate that I did NOT have a product key. Filling in the product key made me reinstall again.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS