• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

[SOLVED] How to disable multiple desktop feature?

coldfunk

Distinguished
Oct 18, 2012
35
1
18,545
0
This has been bothering for a while now and happens pretty often. For my htpc I use a wireless Logitech Keyboard that has a touchpad for the mouse function (K400r). Very often when I swipe across the screen to the right, say to close a window, it minimizes my desktop and opens an "overview" to create a new desktop. This seems to be related specifically to the touch pad. It's random but happens very often and is very intrusive. I found a way to more or less trigger it manually, if I specifically place my thumb on the edge of the touch pad and swipe to the right (similar to how you pull down the top menu on an android, starting from the edge) then it happens maybe half the time. But even moving the mouse a few inches anywhere to the right can trigger this. Very annoying, especially when it happens 3 times in a row when I'm just trying to close a darn window.... It doesn't happen when I swipe in any other direction as well.

Anyways, I'd like to disable multiple desktops completely, I never want to see that overview screen again if possible. I haven't found anything in the settings or anything helpful looking around.

Any help would be greatly appreciated.
 
Last edited:

gardenman

Admirable
Moderator
Hi, read all of this before doing anything.

This is a bit dated but see if it helps: https://cosmicbuddha.com/2018/04/disabling-edge-swipes-for-logitech-k400r-keyboard-on-windows-10/
Important: If you decide to edit the registry, make a valid backup first and be sure you know how to restore it if needed. [Instructions]

Also read the comments at the bottom of the page. Here's one example:
KoiMaxx said:
I found out that if you press fn + right mouse button, the gestures on the touchpad are disabled and the annoying task switcher no longer kicks in. Do note if you turn off the keyboard the setting will reset you will have to press the above key combination again.
Another similar answer here: https://www.reddit.com/r/techsupport/comments/byhqay View: https://www.reddit.com/r/techsupport/comments/byhqay/logitech_k400r_touchpad_triggering_task_view/
 
Reactions: coldfunk

gardenman

Admirable
Moderator
Hi, read all of this before doing anything.

This is a bit dated but see if it helps: https://cosmicbuddha.com/2018/04/disabling-edge-swipes-for-logitech-k400r-keyboard-on-windows-10/
Important: If you decide to edit the registry, make a valid backup first and be sure you know how to restore it if needed. [Instructions]

Also read the comments at the bottom of the page. Here's one example:
KoiMaxx said:
I found out that if you press fn + right mouse button, the gestures on the touchpad are disabled and the annoying task switcher no longer kicks in. Do note if you turn off the keyboard the setting will reset you will have to press the above key combination again.
Another similar answer here: https://www.reddit.com/r/techsupport/comments/byhqay View: https://www.reddit.com/r/techsupport/comments/byhqay/logitech_k400r_touchpad_triggering_task_view/
 
Reactions: coldfunk

coldfunk

Distinguished
Oct 18, 2012
35
1
18,545
0
First of all, THANK YOU so much! This has been bugging me forever, you have no idea hehe.

Second, I feel so silly. I thought for sure it was a W10 feature or shortcut, where it was just how it responded to a specific swipe on ANY touch pad. Why did it not occur to me it was the keyboard itself. Ugh.

So, on to the solution:

On your first link I went for the first solution to disable Edge swipes altogether, but since I have W10 home I do not have a Group policy editor for that solution. Second was trying the registry edit. I did those steps successfully, yet it did not fix the problem (wondering what it actually did then, unfamilar with all that to begin with).

Thankfully though, you read some of the comments, something I might have skipped out of frustration after the four steps did nothing. And the comment you quoted was the solution! I toggled it on and off multiple times to test. It was all so simple all along..

Thank you so much for taking the time! I'd mark your reply as the solution but can't seem to on my end. (edit: just found it)
 
Reactions: gardenman

ASK THE COMMUNITY

TRENDING THREADS