How to remove read only from external hdd

Not open for further replies.
Maybe you need to attrib it in the DOS mode... ??
If you can't do that, then here's something I found that might help, feeling a little lazy to key down all the ways myself so I'm going to just copy and paste....
"Here is what I know:

1. Under the Security Tab in Folder Properties The only group defined there is: “Everyone – Full Control”

2. Under “Advanced Settings - "Owner “ - It shows some long number that starts with "S" , if I try to take ownership and turn it over to administrator, I get something to the effect of “Could not write permission changes”: Access Denied. I get that on all attempted changes, on the programs folder and all of its subfolders and files.

3. The programs folder spoken of above is in the root directory of a partition on one of my drives and is labeled E:/Programs - I normally install all my programs there, all except those that insist on being on C:\Programs, which so far is un-affected like E:/Programs.

4. Both the root above the programs folder (E: the parent) , and the Programs sub-folder itself did not have the usual access permissions
a. The Only security group defined was “EVERYONE” – Full Control
b. No “Administrators” Group
c. No “System” Group
d. No “Creator /Owner” Group
e. No "Users Group"

5. The Root (ESmile showed that the owner Was Administrator in Advanced Properties.

6. Under the security Tab for the root (ESmile I was able to add The ADMINISTRATOR, SYSTEM, AND USERS GROUP, saving the permissions for the root (ESmile was not a problem.

7. Changing permissions in the Root Directory of course had no effect on the (problem) programs folder, I could not even get it to inherit the permissions I successfully created in the root, because of course it could not save (write) the permissions to the ACL for that Folder ! ACCESS DENIED as usual!

Note: I noticed part of this thread mentioned Read Only Attributes that are set on the properties General Tab of Folders and Files, these have no bearing on being able to delete files and folders, using a file manager like Windows Explorer or My Computer !"

"To remove the issue you will need to edit the windows registry file. This addition can be caused to a infection. First go to start menu and then click on run. Type regedit. In the registry editor windows go to file menu and click on export. Save the file to a desired location. This is because in case if there is any error you can restore the registry file back again. Then Navigate to the path HKEY_LOCAL_MACHINE > System > CurrentControlSet > Control > StorageDevicePolicies. Now right click on writeprotect and then click on modify. Change the value to 0 and click on OK. Repeat the same for ControlSet001 and ControlSet002. Close it and restart your system."

The lock can be opened and closed by single command in cmd. Insert your drive and give the chdir command to locate your hard drive. Then type sys: on to enable the write protection and sys: off to disable the write protection service. Also see your bios settings. Some bios have write protection settings. If it is enable then you have to disable it from there.

First click on Start > Run... > regedit > OK

Highlight "Computer" and right-click. Select "Export" and save the backup somewhere safe. Just double-click it if you want to reset the changes you make.

Navigate to the following registry location:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\StorageDevicePolicies

Click on StorageDevicePolicies and on the right-hand side there should be a DWORD value labelled "WriteProtect". If there isn't one, create it. Either way, make sure it has a value of 0. Double-click it to change it.

Do the same with the following two locations (creating any non-existent keys/values along the way):



> go to control panel
>open administrative tools
>select and open computer management
>Under the "Storage" option you will find "Removable storage"
>Right click 'removable storage' and select properties
>You will find a security tab...add yourself and give full read, write & modify permissions..
save and exit. and then copy paste or make changes to the removable storage and it will work..
Not open for further replies.

Similar threads