Question Hybrid laptop not using dedicated GPU after upgrading to Win10

Oct 8, 2019
4
0
10
0
The laptop in question is Asus N61Jv. It's the i3 350M and GeForce 325M version.
The laptop was using win7 and could play 4k video without a hastle. I decided to upgrade it to Windows 10 because i have original windows and win7 is losing support soon.
So, I did that downloaded all the drivers, everything needed, but now, the laptop is not using nvidia gpu.
In device manager it detects it, but doesnt use it at all. It tries to (by changing the side lights to blue it shows it trys to start it a couple of times and then just quits and goes back to using the igpu) but it just doesn't work. In the task manager GPU is not shown in the perfomrance tab.
I clean uninstalled and installed both the igpu and gpu drivers, doesn't work. If i only install gpu drivers it still doesn't work.
Also, back on win7 when i switched from using igpu to gpu the screen would go black for a second, here(when i set in nvidia control panel to use only gpu) it doesn't it shows white light but i know its not working due to bad performance
I don't want to go back to using win7 and i cant roll back to 7 to keep my licence :/
If you have any questions, I'll try my best to provide info that you need cause I'm sure I missed something out.
 

Traditore

Honorable
Open the NVIDIA control panel and go to 3D Settings>Manage 3D Settings. Select the Program Settings tab and click the ‘Add’ button. Browse for the app you want to run with the dedicated GPU (your browser, video player, games, etc), and add it. From the ‘Select the preferred graphics processor for this program’ dropdown, select your GPU.

Try this for every program that needs the power of GeForce 325M

You can also force everything to use the dedicated card in "Global Settings".
 
Oct 8, 2019
4
0
10
0
Open the NVIDIA control panel and go to 3D Settings>Manage 3D Settings. Select the Program Settings tab and click the ‘Add’ button. Browse for the app you want to run with the dedicated GPU (your browser, video player, games, etc), and add it. From the ‘Select the preferred graphics processor for this program’ dropdown, select your GPU.

Try this for every program that needs the power of GeForce 325M

You can also force everything to use the dedicated card in "Global Settings".
Didn't mention I tried that...
It doesn't work :(

Edit: Did*
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS