I can't install the latest AMD Radeon drivers for my RX 570 4gb?

Elf_Knight

Honorable
Nov 9, 2013
647
1
11,015
9
I went to the official website and managed to download the first AMD Drivers for my RX 570 4gb and games run just fine and my PC works fine for media content etc. However, when I clicked scan for updates it says there are new updates to install. So I installed the updates and they installed fine but then it said restart now to install updates. I exited all the idle programs like Steam, Uplay, and Origin but the client would not restart the computer for me. I restarted it myself from the Windows menu but it would not install the updates for some reason and kept saying that there is a new version of updates to install. I believe these are the 2019 updates. Is there anyway I can fix this weird glitch? There is nothing else wrong with my PC.

Specs:
Ryzen 3 1200,
Gigabyte A320 motherboard,
RX 570 4gb Power Colour,
Kingston 240gb ssd,
550 watt Corsair VS PSU,
Cooler Master Case
Stock Ryzen CPU heatsink
 

Crosslhs82x2

Notable
Aug 12, 2017
323
10
815
15
Go to
Guru3d.com
Get ddu= display driver unistaller
Go to your gpu manufacturer website and download the updates.
Follow directions in safe mode.
Once remove install new updates.
 

bignastyid

Titan
Moderator
MERGED QUESTION
Question from Elf_Knight : "Question about AMD Radeon RX 570 graphics drivers..."



 

Elf_Knight

Honorable
Nov 9, 2013
647
1
11,015
9
I reinstalled the drivers and it installed 19.1.1. drivers but now it wants me to install the 18.12.2 drivers. What is going on? I never had any problems installing Nvidia drivers before. I am still getting very bad frame rate.
 

Elf_Knight

Honorable
Nov 9, 2013
647
1
11,015
9
It's a brand new PC this PC did not have any Nvidia stuff. Sorry for the confusion. I have never used an Nvidia graphics card in this PC. Only Ryzen and Radeon for the first time. It turns out it was actually my Internet connection holding me back because I installed drivers for a USB WiFi stick but then took the stick out and plugged in an Ethernet cable to try it out. I uninstalled the WiFi drivers and am only using Ethernet and am getting 60fps on high settings most of the time. I have the latest Radeon drivers too. Many thanks for your help! I played a couple games of Conquest in BFV and am having no issues now whatsoever.
 

ASK THE COMMUNITY

TRENDING THREADS