I cant set my new 960 EVO SSD as my boot drive

Jp_9__

Prominent
Feb 16, 2017
3
0
510
0
OS- Windows 10 64 bit
CPU- Intel core I7 6700 @ 3.4GHz
RAM- Dual channel Samsung 32GB DDR4
GPU- 4095MB NVIDIA GEFORCE GTX TITAN X
STORAGE- NVMe SSD 960 EVO M.2
Motherboard- MSI Z270 Gaming M5

Hello,

I Just recently bought the new "NVMe SSD 960 EVO M.2" and I'm having trouble making this my boot device. I have already updated to the 1.4 BIOS on the motherboard. The Samsung migration software hasn't been updated for the new 960 EVO's so I have used the Microsoft "Media Creation Tool" to download the windows 10 installation software to a USB. I proceeded to disconnect my original mechanical hard drive, that I had been using, from the motherboard. I then opened the BIOS and set my SSD as "Boot Option #1" and the UEFI THUMBDRIVE PARTITION 1 as "Boot Option #2". Next I used the boot menu to boot from UEFI THUMBDRIVE PARTITION 1. I used the Windows Software on the USB to make the SSD one large Unallocated Space and then complete the Windows 10 installation. After the installation is complete it says "Windows needs to restart to continue" and the computer restarts. After the restart it does not boot from SSD but instead from the USB again and brings me back to the start of the installation process. I repeated the loop several times with no success. I have to wipe the hard dirve each time so windows is installing. I tried booting without the USB and only having the SSD as a storage device but it just goes to a black screen and tells me to select a proper boot device. Please Help!

Thanks,
Josh P
 

Jp_9__

Prominent
Feb 16, 2017
3
0
510
0


Drivers for what? I have the firmware downloaded for the SSD.
 

Jp_9__

Prominent
Feb 16, 2017
3
0
510
0


I will look into it
 
On some mobos you have to do this to add the driver. Cant remember what this is for. I just got it from some site

In case I decide to get an NVME for this

1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.

2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in, I don't think this would work with previous versions.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode.

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and windows will finish the install.

I dont know if below applies to you or anyone else


Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives. Do not put anything on SATA port 1 as this is now reserved for the NVME drive.

I would also recommend installing the Samsung NVME driver at this point to replace the Windows one.

The background here is NVME SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector.

Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver.


Make sure you do not use SATA port 1 from that point forward!
 

mechanich

Prominent
Aug 31, 2017
6
0
510
0


So i am in the same boat as Jp....pretty much identical, i used your method and still did not work , because after installing widows and i hit f2 to change boot priority i do not see boot manager, so im forced to turn on CSM on so the bios can see the 960 evo. i also have a 850 evo which i installed windows 10 perfectly on and i boot that up and i see that windows does see the 960 evo and i am able toformate it and make it into a storage device, but the strange thing is that when i pull up device manager i see 3 drives instead if 2. in this order microsoft storage space device, ssd 850 , ssd 960. i keep trying to install windows on the 960 and still no luck, can you help ?
 

mechanich

Prominent
Aug 31, 2017
6
0
510
0


Are you sure,, because im on samsung site now and i see it there
This driver supports Samsung NVMe SSD 960 PRO, 960 EVO and 950 PRO.

· NVMe Driver3.5MBVersion 2.2
 

mechanich

Prominent
Aug 31, 2017
6
0
510
0


http://www.samsung.com/semiconductor/minisite/ssd/download/tools.html

i did that too still hasnt solved my problem,, i think whats happening is that its not seeing or intalling the boot manager on to the ssd, or not letting me access it in bios., because i dont see it as an option, right now im trying to figure out how to manual install the windows boot manager. let me know if you have any ideas.
 

jaed

Prominent
Nov 3, 2017
3
0
510
0
About the CSM..... when everything is running fine under windows, installed on the csm, can we then go back into the bios and put it back at its default value as soon as the nvme is recognized?
 

Similar threads


ASK THE COMMUNITY