Question I have 120+ fps but my game stutters

May 6, 2019
26
0
30
0
Hi, I have an old monitor and an old PC in general. When I play Minecraft, I get 120+ fps almost all the time but the game stutters on the monitor. my monitor is an LG Flatron E1942 1366x768 60hz and it looks like its running at 15 fps. When playing single player, it seems to run at 60, I don't think the PC specifications are needed. Thanks in advance!
 

boju

Champion
Your problem could be cpu usage too high or not enough ram causing too much hdd/ssd io activity so it is considerate to include specs and help those trying to help you.

List specs plz and share some background information on whether it was ever good before?

How are you monitoring fps? Have you tried Vsync to synchronised frames to prevent frame skips?
 
May 6, 2019
26
0
30
0
Your problem could be cpu usage too high or not enough ram causing too much hdd/ssd io activity so it is considerate to include specs and help those trying to help you.

List specs plz and share some background information on whether it was ever good before?

How are you monitoring fps? Have you tried Vsync to synchronised frames to prevent frame skips?
GPU: Gigabyte Radeon R7 240 2 GB GDDR3
CPU: AMD FX-8320, 3.5 GHz
MOBO: ASRock 970 Pro3.0 R2.0 (or 990FX extreme3, i don't know)
HDD: SATA 1000GB (not sure what the exact model is)
RAM: 2 Adata sticks 4 GBs each
PSU: Cooler Master RS-600-ACAB-M2

also i am monitoring fps and usage through MSI AfterBurner. FPS doesn't seem to go down, it just looks very laggy. Usage also stays exactly the same, and I have tried the same with shaders and different versions. the FPS seems to fix only when I load 1.8. Also, I have tried VSync, it doesn't change anything
 
What's happening is that even though the GPU is rendering 120 separate frames per second, they are not in sync with the monitors refresh window. The end result is frames are being rendered but not displayed, resulting in the output appearing jerkey because of skipped frames.

As a first step, set Vsync to the opposite to whatever you have it set to now, and see if that helps.
 
May 6, 2019
26
0
30
0
Sounds like vsync to me. You're way over the refresh rate so that alone won't look good.

Try limit fps instead.
What's happening is that even though the GPU is rendering 120 separate frames per second, they are not in sync with the monitors refresh window. The end result is frames are being rendered but not displayed, resulting in the output appearing jerkey because of skipped frames.

As a first step, set Vsync to the opposite to whatever you have it set to now, and see if that helps.
The only way to remove that stutter is by setting the FPS limit to 30, nothing else would help except going back to 1.8
 

ASK THE COMMUNITY

TRENDING THREADS