Question I need help with my pc

Feb 17, 2019
2
0
10
0
I got this pc from my uncle, im 14. I had a ‘cpu error’ on my pc so i wanted to clean my cpu fan. I cleaned it and all and unplugged some wires and plugged them back i but my pc doesnt start up anymore.
 
Feb 17, 2019
2
0
10
0
Would check to be sure they are all plugged into the proper place, and tightly.
I am not great with computers though. I think i plugged them all in the right places but i dont know the names of the cables and stuff. And i also have 2 lights shining in my pc when the power is on. 1 green and 1 red. Does that mean i plugged them in wrong or something like that?
 

PC Tailor

Respectable
Jun 29, 2017
1,136
24
2,665
317
Unfortunately we would need far more information. We would need full system spec. Or better yet you would need your motherboard manual to identify firstly if you are making the appropriate connections, and also to identify the potential debug lights you are seeing.

Frankly if you are not quite comfortable, take it to a PC shop for them to repair.
 
Feb 13, 2019
8
0
10
0
If you could provide your Computer name, and the brand and model of your Motherboard, that would help a lot.

But my first guess is that if it doesn't start up now, good chance you didn't plug the cpu fan into the right spot. Often computer's won't start unless your cpu is plugged into the correct port. It will read as an open signal or no cpu fan, then it won't even start at all.

The other is if your CPU power is plugged in wrong. I fixed a pc once by rotating the cpu power connector into the correct position then plugging it in. They had shoved the connector in wrong (I have no clue how) and it prevented the pc from starting
 

ASK THE COMMUNITY