[SOLVED] Integrated graphics not connected in my Ryzen laptop

vengeance910

Honorable
Oct 31, 2015
6
0
10,510
0
I have a Lenovo Legion 5 laptop with R5-4600H and my int. GPU is not showing up in my task manager and the device manager says the device is not connected. I have updated all related drivers and my discrete GPU is working fine. It was detected about a week ago but I'm not sure when it's not connected anymore as I only noticed it when my battery dies quicker than before. If anyone that can help needs more info i'll be happy to provide.
 

Lutfij

Titan
Moderator
What version of Windows 10 are you on at the moment?

Might want to see if the laptop has any BIOS updates pending. You might also want to use DDU to remove your GPU drivers. You should then source the latest drivers from AMD's support site(though you should source the drivers from Lenovo's support site for the laptop, to be sure), reinstall the latest GPU drivers manually in and elevated command, i.e, Right click installer>Run as Administrator.

6 month old reddit but similar idea,
https://www.reddit.com/r/AMDHelp/comments/gjr41o View: https://www.reddit.com/r/AMDHelp/comments/gjr41o/amd_ryzen_7_4800h_issue/
 

Lutfij

Titan
Moderator
What version of Windows 10 are you on at the moment?

Might want to see if the laptop has any BIOS updates pending. You might also want to use DDU to remove your GPU drivers. You should then source the latest drivers from AMD's support site(though you should source the drivers from Lenovo's support site for the laptop, to be sure), reinstall the latest GPU drivers manually in and elevated command, i.e, Right click installer>Run as Administrator.

6 month old reddit but similar idea,
https://www.reddit.com/r/AMDHelp/comments/gjr41o View: https://www.reddit.com/r/AMDHelp/comments/gjr41o/amd_ryzen_7_4800h_issue/
 

vengeance910

Honorable
Oct 31, 2015
6
0
10,510
0
What version of Windows 10 are you on at the moment?

Might want to see if the laptop has any BIOS updates pending. You might also want to use DDU to remove your GPU drivers. You should then source the latest drivers from AMD's support site(though you should source the drivers from Lenovo's support site for the laptop, to be sure), reinstall the latest GPU drivers manually in and elevated command, i.e, Right click installer>Run as Administrator.

6 month old reddit but similar idea,
https://www.reddit.com/r/AMDHelp/comments/gjr41o View: https://www.reddit.com/r/AMDHelp/comments/gjr41o/amd_ryzen_7_4800h_issue/
Solved after updating BIOS and reinstalling driver from the Lenovo page, thanks
 

ASK THE COMMUNITY

TRENDING THREADS